How do i get unprocessed one-shot samples in my remix deck

Problem: One Shot samples inside the remix deck, which are getting triggered by the internal step sequencer, are either getting pitched (with keylock off) or weirdly cut and warped (with keylock on), when the tempo chages.

The per sample sync is turned off.

Goal: I want to have the oneshot samples as is. Unaffected by tempo changes like in any DAW.


Thanks in advance

Comments

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,532 mod
    edited February 2023

    Maybe SYNC is toggled to ON for that particular cell. If so, try turning it off.

    EDIT: Strike that. Check if the deck's BPM differs significantly from the master BPM. If so, you can simply set the deck's (remix set's) BPM to something really close to the master BPM.

  • MrSalty
    MrSalty Member Posts: 5 Member

    Thanks for your answer.

    Problem with your solution is that the Remix Deck BPM is controlling the Step sequencers tempo. And it wont solve the problem if I want to have a constant beat running while i play through my set. (90 - 120 BPM Range)


    Why isn't there an option to just "not warp" the one-shots like in ableton? Am I missing something?

  • Kayya
    Kayya Member Posts: 189 Advisor

    Is it possible to share a video about it?

  • MrSalty
    MrSalty Member Posts: 5 Member
  • MrSalty
    MrSalty Member Posts: 5 Member

    Here is a video file where i show off the problem. The samples get either pitched when changing the tempo. Or weirdly cut when keylock is on even when there is no tempo change.

    I just need the samples to be as is. Without any processing, pitching or cutting. Normal samples.


    Thanks again.

  • MrSalty
    MrSalty Member Posts: 5 Member

    After a lot of tinkering and searching the problem did not get any better. It does not matter anymore. Im just gonna use Bitwig at the same time and route it into an instrument deck. So i got even more possibilities. Sad that the Remix deck is so restricting.

  • lord-carlos
    lord-carlos Member Posts: 2,083 Expert

    I think the one shot sampled need to have the same bpm as the remix deck. I'm not 100% sure if that is the problem, but I know I also have it.

  • Kayya
    Kayya Member Posts: 189 Advisor

    Sorry to reply late my friend. I was able to watch late because I was on mobile. As far as I watched the video, I saw that the problem was that the sound was not coming out.

    Such a situation seems like a mistake. It didn't happen to me. I won't be able to answer.

    When I first read about it, I thought that since my English was bad, the main problem would be the shift in rhythms in the step sequencer. According to him, I was going to comment, but I have no experience in this regard.

  • zephry
    zephry Member Posts: 560 Pro

    The Remix Deck is synced to the Bpm you choose. The ability to set the remix deck bpm separately is to closely match all the bpms of the samples.

    For one shots and sequencer, I don't think the bpm and length matter much. The sequencer should only play length according to bpm.

    So it won't be triggering a long riser or long bass sounds. It should (if settings are correct), just cut off. And if you do have a loop or vocal as long as it is set correctly Traktor isn't going to change the pitch either (in the sequencer it should just be cut off).

    If I remember correctly, quantize on the remix deck should to be off. And the samples all set to oneshot. I don't remember sync really sounding much different, but not a bad idea to turn that off for each sample too.

    I attached a picture of what the individual samples settings should look like for sequencer in remix decks.

    It's been a while since I made or played remix sets.


Back To Top