Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

Can't see most of my Arturia plugins in Komplete Kontrol

Ramnotna
Ramnotna Member Posts: 2 Member
edited February 2023 in Komplete Kontrol

Hi there.

I'm using Komplete Kontrol which is a part of the Komplete Now subscription. Mini Mac M1 with macOS Monterey. For some reason only a handful of my Arturia Collection 9 plugins show up in KK main menu, and the ones that show up do not work.

I have tried to re-install both the NI and Arturia stuff but no luck. Has anyone had the same experience and found a solution?


Tagged:

Best Answer

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @Ramnotna First of all make sure that Komplete Kontrol, your DAW and the Arturia Software Center all have Full Disk Access: How to Enable Full Disk Access on macOS

    Are you able to load the Arturia plug-ins from the drop down menu?

    When you say that they "do not work"; what do you mean exactly? What happens when you try to load them, do you get this error message? KOMPLETE KONTROL / MASCHINE Error: "*Product* could not be loaded, as it may not support Apple Silicon or VST2 to VST3 migration."

    Arturia needs to update their products, only for the NKS part, the one that enables the presets on the left browser to load. They are still connected to the VST2 plug-in versions. These VST2 versions are not supported if you use the ARM native version of Komplete Kontrol. You could try to run Komplete Kontrol in Rosetta mode to see if the plug-ins show and work. How to Open Your DAW Using Rosetta

  • Ramnotna
    Ramnotna Member Posts: 2 Member

    Thank you for the tips Jeremy. What I mean by "does not work" is that they do not show up in the list (as shown on the screen shot) and when a preset is selected in KK a prompt pops up telling me that the instrument can not be loaded. I am running everything in Rosetta mode, both the NI and Arturia stuff.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @Ramnotna And all apps have Full Disk Access? Are the plug-ins showing there?

    Please try resetting Komplete Kontrol's database:

    Reinitialize the KOMPLETE KONTROL Database

    1. Go to the following location on your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
    3. Note: The User Library folder is hidden. See this article for instructions to access hidden macOS folders.
    4. Search through the Native Instruments folder at this location to find the KOMPLETE KONTROL folder.
    5. Delete only the KOMPLETE KONTROL folder found here.
    6. Note: Deleting other NI product folders could result in unexpected behavior with other applications.
    7. Reboot your computer and reopen the KOMPLETE KONTROL software to check that the issue has been resolved.


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    Answer ✓

    No news from you for a while. We’re closing this thread now. If you still need assistance on that topic, please get in touch here: http://bit.ly/NIsupport_KKontrol

This discussion has been closed.
Back To Top