Battery 4 rescan button not working

cliff turner
cliff turner Member Posts: 8 Newcomer
edited March 2022 in Battery 4

Recently I moved my libraries to an external drive and I'm having problems with Battery not seeing things . Changed location in Native access , but when I go to rescan within the library , the rescan button doesn't work . Tried in logic and stand alone

I'm also having problems with my user presets . I can see the kits within Battery within logic , but they're empty . I've tried putting the actual files /samples in different locations in my user name and application support but still nada .

I've tried reinstalling battery but didn't help .

1 year old iMac with Big Sur 11.6.2 . NI all latest updates . Using logic .

I've found Battery clunky since going to Big. Sur and it was late with official support . Early with support on Monterey , but Kontakt not official and I use that more than anything. Have messaged re being involved in beta for that reason . hoping that might fix the issues but wondering if I've overlooked something .

Any suggestions?



Best Answer


  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    This will not solve your problem, but it appears with this change in 4.2.0...

    IMPROVED Scanning for content now happens in the background without a blocking overlay

    That they did not add any indicator to let you know it's actually scanning like in Maschine or KK...those apps have a little circle progress indicator...but not in Battery!

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,437 admin
    Answer ✓

    Hi Cliff, for factory libraries, have you tried all the steps listed on this page here?

    The BATTERY 4 Factory Library Does Not Appear in the Software

    As for user presets, can you try creating a user presets folder in My Documents folder and point Logic to that folder in the Locations Preference? Also worth checking if Battery 4 and Logic still have a full disk access just in case!

  • cliff turner
    cliff turner Member Posts: 8 Newcomer
    edited February 2022

    Thanks for that Kaiwan

    Will Work through that .

    looked for message function on forum , but can't find it . On a other thread

    I asked to be put on the list for the beta version but haven't heard back . Is that something anyone can ask for or more for long term members . Is that something



  • cliff turner
    cliff turner Member Posts: 8 Newcomer

    Blind Eddie

    Thanks for that . I hadn't picked up on that , but sadly didn't fix the underlying reason as to why I needed to rescan.

    Kaiwan , I didn't have full disk access turned . Turned on . I started using an external drive recently ( Lacie SSD Rugged 2 Tb ) . That's fixed most of my issues .

    BTW it would be nice to have the spinning wheel in battery so you know the rescanning is happening .

    Have one remaining issue but as it's unrelated to initial thread , I'll start a new thread .



  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,437 admin

    @cliff turner said

    Kaiwan, I didn't have full disk access turned.

    Glad it does the trick.

    BTW I'll give our team a nudge. You should be invited to the Kontakt beta in a couple of days.

Back To Top