Komplete Kontol 2.80 Breaks 3rd Party VST3 Plugins

Options
Native_Robert
Native_Robert Member Posts: 13 Member
edited November 2022 in Komplete Kontrol

After upgrading to Komplete Kontrol 2.8, my Omnivision and Iris 2 VST3s no longer work. Omnivision won't load, and Iris 2 causes an immediate crash.

Is there any way to go back to 2.7?

Best Answers

«134

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,683 Expert
    Options

    Mac I assume……..

    run things in Rosetta mode for now

  • Sebmo
    Sebmo Member Posts: 5 Member
    edited November 2022
    Options

    Same here, after upgrading to Komplete Kontrol 2.8, Spectrasonics RMX is not loading. Can't use the sessions I am working on. I also need to go back to 2.7x but how??

  • Sebmo
    Sebmo Member Posts: 5 Member
    Options

    Thanks. Yes, but if I start my Logic Session in Rosetta it is crashing ?! And takes a very long time to start. I also delete AU Cashes. No help. It works if I start I new session in Logic (in Rosetta) or Komplete Kontrol (what I don't need).

    And just to use Komplete Kontrol, I don't want to run the Logic Session in Rosetta.

    So - back to my question, how can I downgrade to v.2.7x ? Any advise?

  • R3kl355
    R3kl355 Member Posts: 11 Member
    edited November 2022
    Options

    Same Problem here. All was fine in M1 mode and Komplete Kontrol 2.7.2

    Now in KK 2.8 I get the error "Plug-In Preset could not be loaded, as it may not yet support Apple Silicon or VST2 to VST3 migration"

    Perhaps the Recent update to Logic 10.7.5 has something to do with it. Though launching the older Logic 10.7.4 shows it now has the same problem.

    Continuing to test, but yeah, for now Komplete Kontrol needs to be used in Logic Rosetta. Its broken in Logic M1

    EDIT: I was able to copy both the Komplete Kontrol 2.7.2 Application and Audio Unit component from an older system of mine. I have replaced 2.8 and everything is working again.

    EDIT 2: for me, the issues is not only with 3rd party VST’s. Absynth 5 and other things as well.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,985 mod
    edited November 2022
    Options

    It’s Iris 2 that’s broken - outdated plugin no longer being maintained - you really can’t expect Komplete Kontrol to keep working with it indefinitely and Iris is never going to be in a native version - blame iZotope for dropping it not NI

  • Sebmo
    Sebmo Member Posts: 5 Member
    Options

    ? Wrong post? I don‘t have Iris 2 installed on my system?!

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,985 mod
    edited November 2022
    Options

    I’m referring to the OP

  • JesterMgee
    JesterMgee Member Posts: 2,683 Expert
    Options

    Have you read what we have all been saying???

    You need to launch things in ROSETTA mode since even tho a few links in the chain are now M1 compatible, many links are still not (such as most plugins, NKS libraries and everything else on the planet).

    If you want things to work as they did, use Rosetta compatibility mode until you can spend a few days reading up on every manufacturers sites to see if a new version supports Apple Silicon.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,985 mod
    Options
  • Sebmo
    Sebmo Member Posts: 5 Member
    Options

    Yes, and thanks, but I use Logic since April NOT in Rosetta and I am VERY happy this way. I am NOT using a lot of third-party, and I just want to have it back (and stable) before I updated Komplete Kontrol to 2.8. I hope you understand. Again, everything was fine until I updated to this version. And my question is, how I can downgrade to Version 2.7.x . That's all I want to be happy again. 😀

  • JesterMgee
    JesterMgee Member Posts: 2,683 Expert
    Options

    No idea about that, but downgrading will cause the program to run in Rosetta mode as far as I understand since it is not M1 compatible in 2.7 so you really aren't fixing anything there. KK is now "Native" with macOS ARM and so it will automatically disable things that are not compatible. To force it back to how it was in 2.7, that's compatibility mode.

    If you really feel you have to go back to 2.7, can't help you there but to simply say backups before updating are probably a good idea.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,985 mod
    Options

    Thing is Rmx is supposed to be ARM native now so maybe it’s that that needs updating or at least let Spectrasonics know it is unstable in native mode in Maschine

  • Sebmo
    Sebmo Member Posts: 5 Member
    Options

    Thanks JesterMgee and Kymeia, I know 2.7x is not M1 compatible, but I always was running Logic NOT in Rosetta mode and it was great. And yes, I just forgot to backup directly before updating, but I do have an older backup I will try what R3Kl35s has done and copy/paste the old version. I hope it works. And yes, I will also contact Spectrasonics. Thanks again.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,985 mod
    edited November 2022
    Options

    Ah I see what was happening. If you were running Logic in native and KK before 2.8 was not native Logic would have been automatically wrapping it in its built in Intel bridge (which seems rather finicky tbh about what it bridges and what it doesn’t - compared to say the one in Bitwig which is more stable in my experience). Now KK is native too it won’t be doing that and although I guess KK would be faster in that scenario it won’t load all the old non native and VST2 plugins and may also not benefit from any sandboxing built into the bridging process.

Back To Top