No sound from Logic Pro X

Andrearg
Andrearg Member Posts: 4 Newcomer
edited October 2022 in Komplete Kontrol

Hello,

I'm new to the Native Instrument ecosystem and I'm having a problem recording into Logic Pro X. I select Kontakt as the plug-in. I's using the West African drums. There is nothing happening when I record. It appears to be creating a midi track but when I play it back there's no sound. It will record the sound of the metronome but nothing else. There appears to be no signal on the channel strip.

my info:

Macbook Pro 2017, OS Monterey 12.4, 3.5ghz Dual-core Intel i7 processor, Logic Pro X 10.7.4.

Komplete Kontrol S88 MK2, Native Access 2, Komplete 14 Ultimate.

Can somebody tell me:

  1. If I have something set up incorrectly
  2. Is there a specific order that I should open everything in? Native Access first? Or Komplete Kontrol or Logic or the S88? I had to reboot at one point and I want ot make sure I'm doing everything right.

Thanks so much!

Andrea


Thanks.

Tagged:

Comments

  • oubiwann
    oubiwann Member Posts: 2 Newcomer
    edited November 2022

    I may have run into something similar:

    1. I turned on a new S88 MK2, and Logic asked if I wanted to add it as a controller (clicked yes)
    2. All my plugins in the project got disabled
    3. I attempted to create a new SW instrument track, and got the error message "Maximum number of Software Instrument tracks" (Logic seems to think I have 1000 SW instrument tracks already)
    4. I then attempted to record an acoustic instrument, and got the error "Core Audio is not available" (which is odd, since Core Audio is enabled in Logic settings)

    I'm attempting to troubleshoot this now -- in the event that I come up with something useful, I'll post a follow-up here ...

    Oh, in the event that your issue is different (and maybe simpler than mine), have you checked the preferences in the Komplete Kontrol software? When I first started it up after turning on the S88, my apollo twin interface didn't show up and I couldn't hear anything. Rebooting the interface fixed that. (Sadly, this didn't fix my Logic Pro issues ...)

  • oubiwann
    oubiwann Member Posts: 2 Newcomer
    edited November 2022

    Okay, the fix was super-simple: just needed to force-quit the Core Audio process and let macos restart it.

    Everything worked after that!

    For future users experiencing this problem, additional symptoms included:

    1. extremely high CPU usage in Kontact plugins (running in Komplete Kontrol)
    2. random and rapidly changing MIDI values for mod wheel, expression, dynamics, etc.
    3. stuck MIDI notes that would keep playing (driving the total polyphony quite high, also driving CPU usage up)

    Also note that before the force-quite of Core Audio, other audio applications (e.g., Element, which hosts VST and AU plugins) ran just fine, receiving MIDI from the S88 with no ill effects: no stuck keys, no weird/random modulation changes, and no high CPU usage.

    It may be that audio in Logic Pro and Kontact plugins were hosed due to whatever issue was triggered in Core Audio by the setup of the S88 (setup, which I noted above, was initiated by Logic Pro itself, when it identified the new S88 device when I turned it on).

  • Storm23
    Storm23 Member Posts: 1 Newcomer

    Hi @Andrearg! I am having the exact issue. When I put the Maschine in midi mode I get a midi template page, but I can no longer trigger the sounds unless I disable midi mode. I followed this instruction video exactly (https://support.native-instruments.com/hc/en-us/articles/115000864749-Recording-MIDI-Notes-in-Logic-Pro-X-from-MASCHINE-VIDEO-)


    Did you ever figure it out?


    Thank you!

    Specs:

    iMac Pro (2017) - 12.4, Logic Pro 10.7.4

    2.3 GHz 18-Core Intel Xeon W

    Maschine MK3

  • Andrearg
    Andrearg Member Posts: 4 Newcomer

    @Storm23 Here’s what I figured out. Make sure that NI and Komplete Kontrol are running. That sounds simple but after rebooting my Mac, I restarted both NI and Komplete Kontrol and it worked. Hope you were able to get it going.

  • Isaiah Jones Jr
    Isaiah Jones Jr Member Posts: 1 Newcomer

    I was experiencing a similar situation. On your Kontakt Player, try switching the midi channel to Omni. That worked for me!

Back To Top