NI Noire - bug with Cubase tempo track?

dickiefunk
dickiefunk Member Posts: 3 Sine
edited February 2022 in Kontakt

Hi,

I’ve recently picked up Noire and recorded and piano track in Cubase 10 Pro tonight. I needed to slow the ending down so I used the tempo track using a ramp and there was an awful constant glitching sound which sent the Kontakt CPU meter to 100%!? I own around 10 other piano libraries including some that are significantly larger and more cpu intensive yet I don’t have this issue with any of those? This bug doesn’t occur when using tempo jumps but it does with tempo ramps?

My interface is a MOTU 828es and the buffer is set to 128. If I increase the buffer this issue goes away but I’m surprised I need to considering this library is much smaller than some of the large piano sample libraries I own?

Tagged:

Comments

  • glittle
    glittle Member Posts: 2 Noise

    That's been a bug for quite some time. Discussed, among other places, here:

    While the fix described there (removing the replika delay) does work temporarily, unfortunately the problem returns the next time the instrument is instantiated, for instance when re-opening the project. Also, I was unable to make an nki/nkm/snapshot made the change permanent. I think the replika delay is being re-enabled in a locked script as part of the load process or something.

    The upshot is that I use a lot of varying tempo, and going through the process constantly became too much friction so I ended up just basically not using Noire. Interesting to see that this is still an issue. If NI can't fix this in K6, it would be great if they could at least give us a custom Noire nki/nkm that did not re-enable the replika delay upon load.

  • glittle
    glittle Member Posts: 2 Noise

    Oh, and I'm using an RME Multiface and Cubase 10, but I don't think it's a Cubase problem. Unfortunately for me at least, increasing the buffer enough to get rid of the glitches creates too much latency for the piano to be playable.

  • tbrown92030
    tbrown92030 Sacramento, CA, USAMember Posts: 8 Sine

    And here we are at the end of the year and the problem still exists in Noire with the Kontakt 7 Player. I'll note that I have only the player and not Kontakt Full which means I cannot even temporarily remove the Replika delay from the FX chain (enabling/bypassing the effect does nothing).

    I, too, would love a custom patch that does not include the Replika delay at all.

    I'm using Reaper v6.71 so I feel confident in saying this is definitely not a DAW problem.

  • tbrown92030
    tbrown92030 Sacramento, CA, USAMember Posts: 8 Sine

    A quick update...

    While working with NI tech support on this issue, I was able to narrow the problem down to my audio settings in Reaper. I use a Steinberg Audio Interface and the Yamaha/Steinberg ASIO driver for it. I had my settings for the ASIO driver optimized for vocal recording (low latency) and had a fairly small block and buffer size. Increasing these to around 1024 samples has resolved this issue for me.

Back To Top