Is it possible to choose which MIDI channel Komplete Kontrol responds to when loaded in a DAW?

OmniFace
OmniFace Member Posts: 3 Sine
edited September 21 in Komplete Kontrol

In Kontakt you can load multiple instruments in the same plugin instance and set them to different channels. You can then use keyboard split mode in the Komplete Kontrol keyboards to play each separately using a zone on the keyboard.

EDIT: I wish to do the same with Razor in Reaktor, NOT Kontakt...


I'm aware Komplete Kontrol can't load multiple instruments, but I was hoping to to do something similar by loading multiple instances of the Komplete Kontrol plugin in a single track of my DAW (Reaper), and then assign them each a unique MIDI input.

I don't see that this is possible so far. Am I mistaken?

I wish to do this because I'm setting up a single project that will contain a full set list of songs to play live. To keep the size of the project down, I want to load each song into it's own track with all of the instruments that should be played live for that song. Ideally, I might even load all the songs into one track and use automation to enable/disable the instances of the plugin.

I was hoping to use Komplete Kontrol to do this because you can load an instrument AND additional VST plugins in the chain, such as an EQ to hi pass the output or reverb and compression. That would mean I could simply enable/disable a single KK instance and not accidentally leave on the EQ, reverb, or compressor on, affecting the new instrument.

Unfortunately, if I can't choose the MIDI channel manually, I'll have to make a single track in the DAW for EACH instrument (perhaps 4 per song), and EACH song in the set list so I can mute/unmute tracks as needed.

I would end up with like 50 tracks to manage just for the keyboards... which isn't ideal.

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,331 Pulse
    edited September 21

    KK will accept midi on any Channel, it would be the instrument that is loaded in KK that would determine what channel it receives on… granted I have not tried this approach (but will) , but if you have 2 instances of KK loaded on a track, if each has an instance of Kontakt loaded, make sure the receiving midi channel of the Kontakt library in each instance is set differently… (instance 1 to midi channel 1 , instance 2 to midi channel 2 etc… In theory that should work🤪

    OK, just tried this and it is possible using the Midi Channel approach I mentioned above. Just make sure that the Track in Reaper is set to accept Midi Input on all Channels. Then changing the Midi channel your KB is transmitting on will play the Instrument assigned that channel in the KK instance...you don't even need to disable the other instance, but it would probably free up system resources if you did.

  • OmniFace
    OmniFace Member Posts: 3 Sine
    edited September 21


    Sorry, I realize I wasn't clear. I know Kontakt can do this. So can Massive, or any other synth that has the MIDI selection built into the plugin.

    The problem is that Reaktor doesn't. So if I want to use Razor, or Prism, or whatever, I can't seem to do this.

    If there is a way to tell KK to use only one channel (or even Razor within it) I'd love to know?

    Or can I make a patch in Razor and save it and open that in Kontakt somehow?

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,331 Pulse

    There is a way to change the Midi input Channel in Razor Edit mode, but it did not appear to have any effect... that would be a question for a Reaktor/Razor Guru.... you can however Disable the instance of KK in the FX view window as a workaround...

  • OmniFace
    OmniFace Member Posts: 3 Sine

    You can only edit ensembles in Reaktor if you own the full version of Reaktor, correct? So, although I can do this in Reaktor 5, I can't in Reaktor 6 player. And I can't open Razor in 5 any longer.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,331 Pulse

    Correct, but I just checked Razor in Reaktor Standalone and it appears that changing the input Channel there has no effect either...it plays as if it is hardcoded to Omni... not sure if it is a bug, or I am just not doing something right...again a question for a Reaktor GURU... Note, when I went into Edit mode, Razor was set to Channel 1 by default...not Omni...but still played regardless of the midi channel on the KB.

Back To Top