Guitar Rig does not install correctly.....

JesusJosue
JesusJosue Member Posts: 6 Sine
edited September 7 in Guitar Rig & FX

I download the guitar rig 6 program and it won't open. it closes without opening. i reinstalled it and nothing.

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod
    Answer ✓

    What do you mean by "nothing ? What happens when you launch Guitar Rig from the Applications ?

    If it crashes or doesn't open at all, then follow these steps:

    Go to the following location of your computer: Macintosh HD > Users > *Your User Name* > Library > Preferences

    Delete this file: com.native-instruments.Guitar Rig 6.plist

    Go to the following location: Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments

    Delete the Guitar Rig 6 folder.

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    Navigate to that folder: Macintosh HD > Library > Audio > Plug-Ins > Components

    Delete the Guitar Rig 6.component

    Then open Guitar RIg 6 from that location: Macintosh HD - Applications - Native Instruments - Guitar Rig 6

    And finally when everything works, open Logic.

    Did that work out?

Answers

  • JesterMgee
    JesterMgee AustraliaMember Posts: 672 Saw

    English please

    Translation:

    I download the guitar rig 6 program and it does not open. it closes without opening. I already reinstalled it and nothing.

    Download from where (native access) on what system (win/mac) and open it from what (icon on desktop/applications or from within a DAW?

  • JesusJosue
    JesusJosue Member Posts: 6 Sine

    Hi Jester, I download from Native, is a free package. , Mac system. When I try to open the program for it to install, it already gives an error window.  When I open Daw (logic pro x), I get the error window again, so after doing it many times I have to uninstall it one more time. I have already gone to the Native site and I reload it and the same thing always happens

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod

    @JesusJosue What is your operating system ? Do you have a M1 mac ? Do you get an error message in Native Access ? If so, please post a screenshot. Or do you get an error when you launch Guitar rig 6 in standalone ? Then please post a screenshot of that error message.

  • JesusJosue
    JesusJosue Member Posts: 6 Sine

    This is the message when I open Logic Pro X.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod

    @JesusJosue ok but have you tried to open Guitar RIg 6 in standalone ? Is it working ? Do you have a M1 computer or not ?

  • JesusJosue
    JesusJosue Member Posts: 6 Sine

    Yes Jeremy, I tried to open but nothing…

    I don’t think that my cpu is M1.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod
    Answer ✓

    What do you mean by "nothing ? What happens when you launch Guitar Rig from the Applications ?

    If it crashes or doesn't open at all, then follow these steps:

    Go to the following location of your computer: Macintosh HD > Users > *Your User Name* > Library > Preferences

    Delete this file: com.native-instruments.Guitar Rig 6.plist

    Go to the following location: Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments

    Delete the Guitar Rig 6 folder.

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    Navigate to that folder: Macintosh HD > Library > Audio > Plug-Ins > Components

    Delete the Guitar Rig 6.component

    Then open Guitar RIg 6 from that location: Macintosh HD - Applications - Native Instruments - Guitar Rig 6

    And finally when everything works, open Logic.

    Did that work out?

  • JesusJosue
    JesusJosue Member Posts: 6 Sine

    Thank you very much jeremy for your help, I was able to open guitra rig from your application, I can use the guitar directly but it does not receive midi. When I open Logic I can find guitar Rig, but when I open a virtual instrument channel, there is no signal.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod

    I'm a little confused here. Guitar rIg 6 is an audio effect, it doesn't produce sound on it's own. It should be put as an effect on a track in Logic. If you want to control some parameters with a MIDI controller you would need to open the Guitar Rig 6 MFX (for Midi controlled effect).

  • JesusJosue
    JesusJosue Member Posts: 6 Sine

    yes, I was experimenting a lot last night and realized this. Thank you @Jeremy_NI for your great help. Everything is working very well. Thanks

Back To Top