How to solve a malfunctioning Komplete Kontrol S88?



  • George3121312
    George3121312 Member Posts: 2 Newcomer

    To be honest, 1 week usage of s88, and today, sunny morning, i start the day with this issue.

    Is that okay, NI , that many ppls got this problem? Even from the start? I tried cables reconnected/change but it doesnt helped at all, yet =./

    All ok, i know that i will fix this problem or...will return the product...

    But still, after you buy instruments 1k+$, its a very annoying and dissapointed thing that there are such an issues =_=

    And also, here are something like "answer" but its not an answer at all. And all customers must spend few days to solve the problem. Seems like weekends will be full of head aches.


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,700 mod

    @DjRenigade If the issue is only happening in Cakewalk and not in Reaper or in Komplete Kontrol in standalone, then it's not a driver/Windows issue.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,700 mod

    @George3121312 You jumped in a thread where the OP posted the solution himself to his specific problem, even though the chosen title is quite generic. If your symptoms are not exactly the same, it's probably better to create your own thread.

    Also keep in mind that this is a user forum, even if some representatives from support, like myself are here to help out, it's not a substitute for customer support. There is a big Support button on the top of this very page.

    Now, for the issue you are having I would suggest to follow this article from our knowledge base: My KOMPLETE KONTROL Keyboard Does Not Start

    If that doesn't workout then contact our Komplete Kontrol specialists here:

  • George3121312
    George3121312 Member Posts: 2 Newcomer

    It was like a short distance review on a user forum, yep.

    Just sad that we have here software issues, not only NI. And it was not beucase i mixed the settings. Before the night i played keys and was so happy, and after 8 hours, morning, noone touched pc or keys, its just became unplayble.

    After all, i reconnected all cables.

    I saw that my Task manager can see all NI software.

    I deleted Komplete konrol from Native Access.

    Now in my Task Manager i couldnt see NI software and in Komplete Kontrol also wasnt visible a s88.

    Reinstalled ( take a lot of time dont know why).

    Restart pc.

    Then all NI software again returns in to Task manager.

    Turn on Komplete Kontrol - there are again no midi keys connected. Then i just turn ON my s88 and after 2-3secs Komplete kontrol starts to see s88 keys and Screen become alive again. All works as before.

    Just... What a hell?)

    Again, all i needed to do is : reconnect my cables, delete Komplete kontroll APP from Native Accsess, reinstall, reboot. Check all NI drivers and then Komplete kontrol become in shape.

    Its all was a Komplete kontrol app issue, In my opinion.

  • DjRenigade
    DjRenigade Member Posts: 18 Member
    edited May 7

    @George3121312 Happens to me in Cakewalk as well. Done all that too. I downgraded to 2.7.0 and it seemed to work on and off. Now i see that KK has an update to 2.9.2 in NA. Hmmm As it was just 2.9.1 reported by NI. Makes me wonder!

  • purplefeetguy
    purplefeetguy Member Posts: 1 Newcomer

    Gents, make sure any USB connections from your S88 or any MIDI controller goes directly to a power USB (blue). If you don't have enough ports on your desktop/laptop, then make sure your USB "HUB" is at least 2.0 and POWERED". When I say "POWERED" I mean a wall socket, not powered by the desktop/laptop. Make sure the HUB is powered by a separate source of electricity. Some of the smaller MIIDIs have this issue all over their discussion logs. It's even mentioned earlier in some of the comments on this thread...."plugged it into the USB directly (not the HUB) and it magically worked".... paraphrasing but you get the gist.

    Hope that helps....

Back To Top