Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

No Output Sound in Kontakt 6 (and only Kontakt 6) Audio Device Not Listed

Ant G.
Ant G. Member Posts: 19 Member
edited January 2022 in Kontakt

I've discovered there's an apparent issue with Kontakt as it refuses to recognize 1 Windows Audio Device.

In the attached image you'll see a list of the Windows Audio Devices on this PC in the Systray, they are:

1-Realtek Digital Output

2-Realtek HD Audio 2nd Output

3-Headphones (Momentum 3 Stereo)

4-Headphones (Momentum 3 Hands Free)

However, when in Kontakt 6, in looking at the drop down list, entry #2 "Realtek HD Audio 2nd Ouput" is missing. And as a test, I opened my BlueTooth Momentum Headphones and it found those immediately.

When I choose this Reatek HD Audio 2nd Output, all other apps work..be it 3 web browsers, Studio One with Kontakt loaded, Foobar, Itunes, Audacity...simply everything.

When I toggle from one Realtek Audio to the other Realtek in Windows Audio, everything else aligns with this change on the fly. Only kontakt 6 stand alone will not load this 2nd Output entry in the Kontakt Audio Devices thus I get MIDI input but no sound when on Realtek HD Audio 2nd Output. Kontakt works well with all other Audio Devices.

I have reinstalled and rebooted. Anyone else experience this issue with a missing Audio Device in K

Kontakt? if so, what was your solution?

Thanks

Tagged:

Comments

  • Ant G.
    Ant G. Member Posts: 19 Member

    Solved:

    Unlike FM8 or Massive, there 'is' an ASIO option. This doesn't correlate to any other ASIO such as ASIO4ALL but apparently it's Kontakt's own ASIO option.

    If you have selected WASAPI shared or Exclusive, try ASIO instead. This will allow you to toggle between Audio Devices within Windows as WASAPI mode will likely work with only 1 Audio Device

    Here are the basic steps to fix no Output sound

    Click the Gear in KONTAKT

    MIDI - I selected all the Boxes though I could have selected just the MIDI devices needed

    Now click AUDIO

    Driver should be "ASIO"

    Next Device should be REALTEK ASIO (if you have a Realtek Card) or choose whatever audio card you have

    ASIO config sets itself, no need to adjust

    Choose your Sample rate that works well with your card. At the very least 44k though mine goes up to 192k

    Close and Restart Kontakt 6

    PS changing to OMNI from Port A did not assist in this matter

    Hope this helps

  • EvilDragon
    EvilDragon Moderator Posts: 1,019 mod
    edited January 2022

    Kontakt doesn't have "its own" ASIO option/driver - it just selects that type of audio driver to use, then searches for any installed ASIO devices to choose from. If you didn't have any ASIO devices installed you wouldn't be able to choose anything there.

    Do note that choosing a higher sample rate will also increase the CPU usage. Kontakt's sample rate needs to match the sample rate of your audio device as defined in Windows' Sound control panel, for the relevant device.


    Also, FM8 and Massive of course also support ASIO in standalone.

Back To Top