Certain kontakt libraries glitching audio/spikes rhythmically

Michael Dow
Michael Dow Sydney AusMember Posts: 20 Sine
edited August 2022 in Kontakt

Mostly seems to just be the new Stradivari Cello + Violin

Guarnari violin

amati viola

It coincides with random CPU spikes in kontakt that suddenly jump. Up to 78% CPU. Which is just not possible playing one note of a kontakt instrument.

CPU overload protection is off. Multicore support is off, as it says it causes problems (really?? in 2022?)

the CPU meter has always randomly shot all over the place for me in kontakt but not like this. One note shows an average of 20% CPU usage, with lots of 50% 75% spikes.

Disk says 0%

128kb of preload buffer.but it doesnt really make much differenc whatever i put it on.

This is a brand new i7-12700k 64GB ram and running the libraries off a fairly decent m.2 SSD.

I dont seem to be allowed to upload an example mp3 but i'm sure you know what i mean

Also can someone tell me please "offline interpolation quality (for mixdown) setting... it's set to "like realtime" but nowhere can you change what realtime is?


Thanks!

Tagged:

Best Answer

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine
    Answer ✓

    So when i up my lbuffer length from 256 to 512 samples at 48k it seems to stop the spluttering. All good i guess, i just never used to get that on my old i7-2700k for the last 11 years

Answers

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine

    Actually all kontakt instruments including NI own ones, spitfire audio, and more have random CPU spikes while just playing one note. And especially more

    Why isn't it stable? Actually why is it so insanely unstable?. And why doesn't it relate in anyway to the windows CPU meter, or the DAW one.

    Also why does it often say more than one voice is being played, even though one key is held down, no round robins triggered, no extra mics therefore seemingly no other samples playing.

  • Kubrak
    Kubrak Member Posts: 1,516 Pulse

    12th gen Intels are of big.little architecture. It may cause problems, it is new thing to x86 world and Windows.

    1) What version of Win do you have? If things have not changed, 12th gen Intels are supported more or less well by Win11, not by Win10.

    2) Try switch off use of energy effective cores. What may happen is that OS sheduler assigns energy effective core to Kontakt....

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine

    12th gen Intels are of big.little architecture.


    What does this mean?


    I'm running windows 11 yes. Thats intersting about the energy efficient cores. Often if i have my browser open, and i go back to the DAW and play notes, i get more glitch buffer sounds for a short period until it's "woken up"

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine

    Actually, if i play the midikeyboard while my browser is focused, i get constant glitches.


    My browser is brave

  • Kubrak
    Kubrak Member Posts: 1,516 Pulse

    Big.little means that CPU is composed of two brands of cores, "energy efficient" ones and "performance" ones...

    What may happen to you Kontakt thread jumps from performance to efficient ones.... It could create dropouts..

    Try to disable efficient ones. It might be possible in BIOS or Intel provides SW tool to do it. Hard to say, if it helps.... It might.

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine

    After being away from the daw for 3 seconds, the glitches start when i play a note


    Maybe this eco core thing is ***** for DAWs you're right. Or i just dont worry about it because does it matter it glitches a bit if i press some keys while browsing. When i'm fully working on music i disconnect from intern


    Mind you i dont normally write music whiles also browsing the internet so it's no big

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine

    Okay so i disabled the e-cores. Still stutters when my DAW isn't open. So when i playback my DAW track, i get the stuttering.

    It's actually not kontakt specific either. I wonder if it is my ancient motu pci-e424 not liking windows 11.


    I will try my MOTU m4 and see how that goes

  • EvilDragon
    EvilDragon CroatiaModerator Posts: 812 mod

    So did you actually try to enable the multiprocessing in Kontakt? The warning is there because different DAWs respond differently to this option, but from what I saw at least, it's a net benefit in quite a few of them.

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine

    I did, unfortunately it makes no difference

  • Michael Dow
    Michael Dow Sydney AusMember Posts: 20 Sine
    Answer ✓

    So when i up my lbuffer length from 256 to 512 samples at 48k it seems to stop the spluttering. All good i guess, i just never used to get that on my old i7-2700k for the last 11 years

Back To Top