Komplete Kontrol MK2 MIDI template not working

wido
wido Member Posts: 5 Sine
edited January 24 in Komplete Kontrol

I am running into a wall.

https://support.native-instruments.com/hc/en-us/articles/360001144229-Managing-KOMPLETE-KONTROL-MK2-MIDI-Templates

I tried to follow these instructions, however, it does not work.

Here is why I want to do this procedure:

I just brought NI KK M32. I use it on a laptop and on a tower pc. I created templates outside the DAW in KK. I mapped everything in my DAW (Studio One). I synced the file via cloud to my tower. However, starting KK on my tower PC, it will not recognize the file I put in. I will overwrite it with the standard setting.

How do I know that?

First the file size will shrink from 75KB ot 16KB.

Second, if I open the file with text, it is evident, that there is not the same content.


On the picture above one can see the file size is 74KB.


Opening KK MIDI mode, the created templates are not there.


What I tried to solve the issue:

I uninstalled KK from my computer. I deleted the folder in "C:\ProgramData\Native Instruments\Komplete Kontrol". I installed KK again. Before opening KK I place the DAT file into the folder. I have the file from my laptop. I start up KK, enter MIDI mode to configure templates. And there is still the standard preset template. After closing MIDI mode, the DAT file shrinks from 73KB back to 16KB.

There is something not right, and I can't figure it out.

What I noticed is that, if I plug in the MK32 into my laptop, the little display instantly shows the last template I used. Unplugging the device and plugging it into my tower pc, the little display shows instantly the template name I last had on the tower pc. This is happening with KK NOT open! It appears as if the device is recognized and as if there is a cache somewhere holding on to the old setting. Then once KK is open, as mentioned earlier in this text, KK overwrites the file (see pictures).

Anyone else having the same issue?

Thank you in advance for your help!

Best Answer

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw
    Answer ✓

    OK, after bit of troubleshooting, found a fix... Copy the dat file to the location and set to read-only (thanks @JesterMgee for that tip) then restart the NIHostIntegration Service. The templates should now show up on the controller. Then remove the Read-only from the Dat file (if you are going to make changes)

    There is no date on the article, so something may have changed with newer versions of the SW???

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw

    This is not an actual answer, just a confirmation that I was able to replicate this behavior. @Jeremy @ NI

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 386 Saw

    Can't say I have tried to backup that file and copy to another computer but with the template being "cached" this is correct, the keyboard itself stores a template on-board for use when the keyboard is not running with KK software.

    According to the instructions linked, the template should work. What about instead of synching with a cloud folder you just copy manually using a USB stick as a test then if there is no change, try set the file as "Read-Only" and see if it manages to pull up the settings without overwriting.

    Also what happens if you try go the other way and save a template from the other system and copy it back the other way?

  • wido
    wido Member Posts: 5 Sine

    Thank you for your answers.

    It is "good" to see, that someone else was able to replica the issue.


    I tried not to sync via cloud. In fact, I deactivated syncing this folder altogether, until I have solved the issue. I tried putting the file manually into the folder.

    I tried "read only".

    I tired opening actual file, copy past the content into the existing file.

    I am running KK as administrator.


    Nothing worked so far.

    I contacted NI support now.


    I am curios if there is a way to reset the hardware (NI KK M32) to factory settings. With the idea of empty the "on board cache" ...if there is such a thing.


    Thank you again for all the responses so far.

    (Worst case, I have to write all the designations in my templates again. Nothing complex yet.)

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw
    Answer ✓

    OK, after bit of troubleshooting, found a fix... Copy the dat file to the location and set to read-only (thanks @JesterMgee for that tip) then restart the NIHostIntegration Service. The templates should now show up on the controller. Then remove the Read-only from the Dat file (if you are going to make changes)

    There is no date on the article, so something may have changed with newer versions of the SW???

  • wido
    wido Member Posts: 5 Sine

    @Blindeddie

    I applied your suggestions....aaand, I am happy to tell you, you are my hero!

    Your fix worked. Thank you so much!


    I am wondering if syncing via cloud service would work? If the problem is only solvable by the trick you just found, then cloud sync would not work. That would not be the end of the world. Once I set some templates, I am not changing them every day.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 640 mod

    Hey @wido We don't recommend to put our plug-in or other files on virtual drives or cloud services. It does create a lot of issues with our products.

Back To Top