Problem with Kontakt, Komplete Kontrol and DAWs. Can’t use the Librarie’s tab search box of Kontakt.

ChoPraTs
ChoPraTs Member Posts: 10 Sine

Hello everyone.

Since I have my NI Komplete Kontrol S88 MK2 keyboard, I am trying to modify my templates in the DAW to replace each Kontakt instrument instance by the same instrument loaded into a Komplete Kontrol instance, so that I can take advantage of all the keyboard features like displaying the register of the instrument on the illuminated LEDs of the keys.

But I’m suffering something very annoying that bothers me a lot.

I use Komplete Kontrol's “Edit View” because I like to view the Kontakt interface as before. When I open any instrument track of my projects and try to edit or change the used instrument (I repeat: Kontakt is loaded as VST or VST 3 into a Komplete Kontrol instance), I can't use the search bar in the Kontakt Libraries' tab. Every time I open the instrument from the DAW and try to type a word in the Kontakt Libraries browser search box, only the first letter of the word is typed and the following letters are not typed, they are considered by the DAW as keyboard shortcuts. It is something really annoying.

For example, if I try to type “Cinematic” in the search box of the Kontakt Librarie’s Tab, only the letter “C” is typed and immediately after that the “i” and the rest of the keys are interpreted as if they were shortcuts, which sometimes causes a bunch of unwanted changes in the project. In order to type the rest of the word I have to make sure that I manually select the search box clicking with the mouse again after typing the first letter, which hinders the flow work and instrument changes. 

This problem happens in all the DAWs that I have tried: Logic Pro, Cubase, and Reaper, so I understand that it is a problem with Komplete or its integration with Kontakt, not something related to the DAW itself.

If I insert a Kontakt instrument directly on the track instead of loading it into a Komplete Kontrol instance, there is no such problem and I can perfectly search entire words without interruption. There is also no problem using the standalone version of Komplete Kontrol.

Has anyone else experienced this problem? Let's see if someone has found a solution.

I use the latest versions of Logic Pro, Cubase, Reaper, macOS Monterey 12.4, Komplete Kontrol 2.7.2, and Kontakt 6.7.1.

Thank you very much!

Answers

  • Brad Yost
    Brad Yost Anacortes, WA, USA Member Posts: 204 Saw
    edited July 2

    I can't reproduce this on my current DAWs (Nuendo & CbB), but did find this on the Logic Pro forum;

    https://www.logicprohelp.com/forums/topic/142035-logic-1073-and-plugin-keystroke-handling-problem/#comment-822866

    Check in your DAW that the Plugin window is maintaining FOCUS at all times when typing. (Maybe even just move the cursor over some part of KK to make sure).

    I have 4 monitors (similar to multiple monitors mentioned in above thread) and have never had any issues on any of them.

    This has to do with setting focus so that all keystrokes go to plugin when it is in foreground. Some DAWs have a preference setting for this, or a toggle on the header of the plug window itself. [for ex: in any DAW that I have used (on WIN10), GR5/6 always has to have 'all keystrokes applied to plugin' for me to search, edit, or type in to save a custom preset. Just something that I've gotten used to.]

    Good luck!

    @Jeremy_NI any further insight?

  • ChoPraTs
    ChoPraTs Member Posts: 10 Sine
    edited July 3

    Thank you for your reply Brad.

    Maybe is related to macOS but, as I mentioned in my previous post, there's no problem using Kontakt directly as insert in any DAW.

    I also have two extended Dell monitors in addition to the integrated screen of the iMac. I have tested by disconnecting all monitors and using only the iMac screen and the same thing happens.

    Here I attach a gif with the steps to follow to reproduce the problem. First, with Kontakt inside Komplete, you'll notice that I can't type “cccc” in the search box because it automatically jumps to a keyboard shortcut (Cycle) after the first letter. I must click the mouse again in the box to continue typing. And as you will see later, this does not happen if you use Kontakt directly, then you can perfectly write all the letters in a row.


  • ChoPraTs
    ChoPraTs Member Posts: 10 Sine

    Thank you for your reply Brad.

    Maybe is related to macOS but, as I mentioned in my previous post, there's no problem using Kontakt directly as insert in any DAW.

    I also have two extended Dell monitors in addition to the integrated screen of the iMac. I have tested by disconnecting all monitors and using only the iMac screen and the same thing happens.

    Here I attach a gif with the steps to follow to reproduce the problem. First, with Kontakt inside Komplete, you'll notice that I can't type “cccc” in the search box because it automatically jumps to a keyboard shortcut (Cycle) after the first letter. I must click the mouse again in the box to continue typing. And as you will see later, this does not happen if you use Kontakt directly, then you can perfectly write all the letters in a row.


  • Brad Yost
    Brad Yost Anacortes, WA, USA Member Posts: 204 Saw

    Yep. That is strange.

    I notice that you are using the VST2 version of both Kontakt and KK.

    Have you tried this experiment using the VST3 version (just curious).

    And the Plugin window in Logic (both instances) is focused (white frame when active), but that doesn't completely eliminate anything in Logic being the issue.

    Maybe try to remove Komplete Kontrol and then reinstall it.

    I'm stumped.

  • ChoPraTs
    ChoPraTs Member Posts: 10 Sine

    I'm using Komplete Kontrol as "Audio Unit", because Logic doesn't work with VST. Kontakt is loaded into Komplete Kontrol as VST because KK doesn't work with Audio Unit components. Anyway, I've tried also with VST3 with the same results.

    If it was a Logic Pro issue, then it should work with other DAWs as Reaper or Cubase that I also have. I've tried both and the same problem occurs so I think it's not something related to Logic Pro exclusively. Maybe related to macOS?

  • Brad Yost
    Brad Yost Anacortes, WA, USA Member Posts: 204 Saw

    Boy, you got me. I have not seen that issue before.

    One of my buddies uses KK & Kontakt VST2/3 in Logic Pro 10.7.x all the time without any problems at all on a MBP.

    But I wouldn't put it past being related to your OS.

    Might want to wait until Jeremy or some of the other Genies from NI chime in in a few days.

  • ChoPraTs
    ChoPraTs Member Posts: 10 Sine

    Very strange issue, yes. I don’t understand why is happening in all DAWs but not when using Komplete Kontrol standalone app.

    I've just uninstalled everything, deleted all preferences and folders related to Kontakt and Komplete Kontrol, restarted the entire system and installed both apps again through Native Access and nothing changed. Same problem for now.

    I've also tried to reproduce the issue with other plugins inserted into Komplete Kontrol, as BBC Symphony Orchestra or VSL Synchron Player but they don't have any search box to type text. But SINE player from Orchestral Tools have a search bar and... guess it! It happens the same!

    So, definitely, it's not a problem of Kontakt, it's something related with the search boxes of any plugin inserted into Komplete Kontrol. Maybe also related to macOS, who knows.

    Of course, using SINE Player inserted directly into the instrument track, there's no problem.

    I've a very old MacBook Pro with an older version of macOS, I think it's El Capitan. Tomorrow I will try to install Komplete Kontrol on it and do some more tests.

    Anyway, thank you for your help!

  • ChoPraTs
    ChoPraTs Member Posts: 10 Sine

    I've doing some more tests.

    I attach a new example using Cubase, SINE Player and Komplete Kontrol. Same problem.

    Notice that the blinking cursor in the text box is lost after pressing the first letter on the keyboard, so the following letters are understood by the DAW as shortcuts as when you click at any other button or part of the plugin Window. But, when you click again with the mouse in the search bar for the second time, then there's no problem and you can continue pressing letters without problem.

    I also have tested this with my old MacBook Pro and there's no problem there. It works as expected! But because it's a very old computer, the latest compatible versions are: macOS El Capitan 10.11.6, Logic Pro 10.2.4 and Komplete Kontrol v2.0.4.

    So, not sure if it's a problem related to the latest versions of Komplete Kontrol or maybe something related to macOS Monterey. I don't think Logic has anything to do with it since the same thing happens with Cubase and Reaper and probably other DAWs that I don't have.


Back To Top