Kontakt, FL Studio MIDI routing and instrument focus with multi rack

Apax
Apax Member Posts: 8 Sine
edited June 2022 in Kontakt

Hi there


I'm learning how to use Kontakt within FL studio. Is there a way to keep the focus on the instrument you are using rather than Kontakt defaulting back to the first instrument any time it is clicked?

It doesn't seem to matter which instrument is selected in the navigator and has the orange box around it. Midi outs are used as this seems the only way to be able to record live fader changes to the instruments (without them they change on screen and audibly, but don't record).


This is creating issues as I can only hear the instrument when the midi out associated with the 2nd/3rd/etc instruments is selected and can't change parameters in Kontakt


Kontakt is set to input port 0

The Korg M3 is set to input port 1 in FL studio

Both MIDI outs are set to port 0 to feed to Kontakt

Midi knobs are set to Omni so they only control the faders in their respective channel.


I've tried to record the issue, but it is one handed so hopefully it's clear enough.


With thanks

Niall

Best Answers

  • Apax
    Apax Member Posts: 8 Sine
    Answer ✓

    Hi guys,

    I've managed to find a solution

    For whichever instrument you want to control the parameters for, right click the MIDI out associated with it's channel -> receive notes from -> select all for your midi controller. Then just unlock it when you're done.

    Here's a link to the video that helped me fix it. It walks though everything FL Studio and Kontakt and the creator helped me out in the comments.


    If it's not appropriate to leave this here for others then feel free to remove / let me know.


    Hope this helps someone in a similar position.

    Niall

  • Apax
    Apax Member Posts: 8 Sine
    Answer ✓

    Found a better answer for focus if it helps any FL users. In the General tab in settings make sure "Auto select linked modules" is not selected.

    It was in mine and that's what caused everything to keep defaulting to the first part of each chain (if that makes sense).

    All good and not needing to force focus onto the MIDI outs for each amendment now.



Answers

  • Apax
    Apax Member Posts: 8 Sine
    Answer ✓

    Hi guys,

    I've managed to find a solution

    For whichever instrument you want to control the parameters for, right click the MIDI out associated with it's channel -> receive notes from -> select all for your midi controller. Then just unlock it when you're done.

    Here's a link to the video that helped me fix it. It walks though everything FL Studio and Kontakt and the creator helped me out in the comments.


    If it's not appropriate to leave this here for others then feel free to remove / let me know.


    Hope this helps someone in a similar position.

    Niall

  • Apax
    Apax Member Posts: 8 Sine
    Answer ✓

    Found a better answer for focus if it helps any FL users. In the General tab in settings make sure "Auto select linked modules" is not selected.

    It was in mine and that's what caused everything to keep defaulting to the first part of each chain (if that makes sense).

    All good and not needing to force focus onto the MIDI outs for each amendment now.



Back To Top