Komplete Kontrol integration cubase 12

docho464 Member Posts: 4 Newcomer

I Recently bought mk2 komplete kontrol s49 mk2

Trying to get it to work with cubase pro 12 midi mode

Just like don sigalas video

But not getting any transport /mixer/ functions

Loading Kk software as plug-in works great. tried messing with the settings in cubase and wont let me choose komplete kontrol s series when adding device ,shows as an option but wont add so i can choose kk daw 1 ,

I tried reinstalling, unplugging hardware and checking all updates (native access)

Now kk controller works flawlessly in standalone & in Maschine software

Not sure if i have to remove any drivers tht might not make it work properly in cubase or wht

Any insight will be appreciated

Kk Firmware 0.5.9

Kk software 2.7.2

Windows 10


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @docho464 The integration should work straight out of the bat, you shouldn't need to mess with settings, from the screensjots of the MIDI Port Setup, everything seems to be in the right place. Komplete Kontrol S-Series should show automatically in "Remote Devices (Legacy)"

    Make sure to run Komplete Kontrol and Cubase as administrator: How to Run a Program as an Administrator

    Do you have any other audio program running that uses MIDI ?

  • docho464
    docho464 Member Posts: 4 Newcomer

    I see it remote device (legacy)

    And both cubase and kk software are ran under administrator

    Under audio im running maschine mk3

    But still not working in midi mode

    Im able to play keyboard keys but all transport bottons im getting are just sounds from wht ever plungin i have running , (play ,stop and loop)

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    What you are showing in your screenshot is the Track Quick Controls, not the Komplete Kontrol script. This is how it should look:

    The process to have the whole Komplete Kontrol integration of Cubase should be automatic. Some assignments of the new MIDI remote system from Cubase seem to create conflicts.

    To get it back, the safest way is to reset Cubase to it's factory defaults, here is how to:

    Navigate to this location: C:\Users\USERNAME\AppData\Roaming\Steinberg

    Move the Cubase 12_64 folder to your desktop (just in case to have a copy of your old settings)

    Open Cubase, it should open in it's default state, you should see the Komplete Kontrol S Series entry appear there, like on my screenshot. Transport, mixer functions should all work.

  • docho464
    docho464 Member Posts: 4 Newcomer

    Tried it and no luck

    Even deleted file and restarted cubase 12 intoll dont have komplete kontrol s-series in remote Device legacy

    Like in ur Screenshot

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @docho464 I contacted you by email, we need to have a deeper look in your setup.

  • curnes
    curnes Member Posts: 4 Newcomer

    what was the solution in the end?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @curnes Unfortunately OP stopped replying to my colleagues after a while. If you face a similar issue please get in touch with our specialists here: http://bit.ly/NIsupport_KKontrol

Back To Top