Problem with Arturia Plugins and Komplete Kontrol Keyboard/Software

dangerfreak
dangerfreak Member Posts: 3 Member
edited May 2022 in Komplete Kontrol

Good evening,

when I begin to change presets in the synth plugin itself the Arturia products lose connection to the Komplete Kontrol software. They don't react anymore to Komplete Kontrol preset changes. U-he software products interact with Komplete Kontrol, no matter where I change the synth presets: Inside the plugin or "outside" in Komplete Kontrol: Both are linked and follow each other while changing from one preset to another. Does anybody know if this is an Arturia problem in general or wrong preferences in Komplete Kontrol?

Thanks for your advice

MM

Best Answer

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert
    Answer ✓

    Ok, so first thing, whenever trying to troubleshoot an issue with the KK application it is always best to open the standalone KK app so we can rule out the DAW as the potential issue.

    You probably just need a little guidance on how KK works with plugins.

    But the other way round doesn't work (correctly) in my opinion, because preset changes made in KK Software or in the plugin itself made by mouse should have an effect on each other, shouldn't they?

    Not just your opinion, that is correct.

    NKS is just a "snapshot" of a plugin state so when you load a NKS preset in KK it just tells the plugin what settings to set and that is it. "Some" plugins will also update the preset name/preset list position within the plugin but not all have this ability so not every plugin updates the preset position because it is not really needed.

    Selecting a preset in the actual plugin WILL NOT update KK as to the preset you loaded because the plugin does not send any data to KK to tell it what preset is loaded. Additionally, if the plugin is something modular like Kontakt or a UVI plugin for instance, loading a preset from t he plugin will also cause all your mappings to be wrong for the new instrument.

    This is why you should stick to loading presets from KK when within KK and kind of forget about the plugin browser within the plugin

    As for the rest of the problem, no idea would have to see it in a video to know if it is normal or not, sounds like it's working as expected, just not what you are personally expecting.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    What OS/System etc?

    What plugin specifically?

    Is this in Komplete Kontrol standalone or within a DAW?

    To clarify what you are saying, the issue is that when you choose a preset to load for (any) arturia plugin it will initially load the instrument and the controls appear on the keyboard and all is fine but from there you cannot then load another preset or when you do it does not change your keyboard display to the new instrument?

    Are you doing all this from the keyboard or using the mouse (or both do the same thing).

    Can you post a simple repro step list that someone could follow to try and do the same thing as you?

    No issues this end using any Arturia plugins, tho I really only use Analog Lab myself

  • dangerfreak
    dangerfreak Member Posts: 3 Member

    Hi JesterMgee

    The used OS is MS Win 10 Home Edition latest update - the DAW is Ableton Live 11.1.2.

    I use NI KK-software within this DAW and the Komplete Kontrol S88 Mk2 Controler Keyboard

    This problem occurs while doing this:

    - loading NKS KK onto a MIDI track.

    - choosing any Arturia software synth (it doesn't matter which one)

    - after that the preset lists are shown on the display of KK S88 keyboard correctly, 

    the pre-listen function works fine and the preset change by S88 knobs or by mouse 

    in the preset list of the KK software plugin works fine as well -> this means: 

    the Arturia preset list follows the preset change. 

    But the other way round doesn't work (correctly) in my opinion, because

    preset changes made in KK Software or in the plugin itself made by mouse should have an

    effect on each other, shouldn't they?

    So when I choose another preset directly in the Arturia plugin preset list by mouse, 

    the NI KK plugin doesn't follow and a preset change is now only possible 

    inside the Arturia plugin preset list. NI KK preset changes now have 

    no effect on the Arturia plugin anymore. This disappears first after loading another 

    Arturia plugin and the above described "circus" starts again.

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert
    Answer ✓

    Ok, so first thing, whenever trying to troubleshoot an issue with the KK application it is always best to open the standalone KK app so we can rule out the DAW as the potential issue.

    You probably just need a little guidance on how KK works with plugins.

    But the other way round doesn't work (correctly) in my opinion, because preset changes made in KK Software or in the plugin itself made by mouse should have an effect on each other, shouldn't they?

    Not just your opinion, that is correct.

    NKS is just a "snapshot" of a plugin state so when you load a NKS preset in KK it just tells the plugin what settings to set and that is it. "Some" plugins will also update the preset name/preset list position within the plugin but not all have this ability so not every plugin updates the preset position because it is not really needed.

    Selecting a preset in the actual plugin WILL NOT update KK as to the preset you loaded because the plugin does not send any data to KK to tell it what preset is loaded. Additionally, if the plugin is something modular like Kontakt or a UVI plugin for instance, loading a preset from t he plugin will also cause all your mappings to be wrong for the new instrument.

    This is why you should stick to loading presets from KK when within KK and kind of forget about the plugin browser within the plugin

    As for the rest of the problem, no idea would have to see it in a video to know if it is normal or not, sounds like it's working as expected, just not what you are personally expecting.

  • DomiKamu
    DomiKamu Member Posts: 4 Member

    Hello, I've noticed this behavior, by using lastest Arturia (but as demo) - 28 April/ 04 May 2022 versions. I'm using similar platform (Windows 10 Pro x64 21H2, Komplete Kontrol v2.7.2 R2, REAPER 6.57 x64, Live 11 Lite v11.1.5 x64).

    In my opinion, Komplete Kontrol (2.7.2 R2) isn't the culprit. "Something" from Arturia instrument "blocks" to update the instrument parameters (after preset loaded from instrument browser).

    Another strange thing I've noticed: many Arturia instruments have nks presets (.nksf) but without preview files (.nks.ogg), however a "default" preview occurs when selecting NKS preset from Komplete Kontrol, so I don't understand why (no explanation).

  • dangerfreak
    dangerfreak Member Posts: 3 Member

    Hi Jester Mgee and DomiKamu,

    Thank you for your explanation.

    Yea, now I understand and I agree with you.This ain't a "NI problem", but an Arturia plugin property.

    @DomiKamu : all my Arturia plugins (i.e. Virtual Collection 9 and Pigments 3) work fine within the KK browser with regard to the NKS audio pre"view"

Back To Top