Guitar Rig presets import not working

rcelestin
rcelestin Member Posts: 4 Sine
edited January 18 in Guitar Rig & FX

I've imported .ngrr into GR6 Rack Presets documents files. But those presets don't show up once I open GR6.

What is even weirder is that only one .ngrr shows up in the user rack section of GR6, this is very problematic !


Any ideas?


Thanks

Tagged:

Best Answer

  • Eddie_NI
    Eddie_NI Product Team Posts: 35 mod
    Answer ✓

    Hi rcelestin,

    I had a look at your presets and found an issue. There is a requirement in Guitar Rig 6 that the filename of a preset has to match the preset name that is stored inside the file, if it should be imported. (Various reasons for that). And that is usually the case for all presets. Unless they have been corrupted, maybe during copying or altered manually.

    The presets you sent me don't meet that requirement.

    But I did find a workaround to get your files imported into GR6. I imported them into GR5 via the "File->Import Preset" menu entry (you can also just drag&drop them into the GR5 browser). Then I used the right-click "Export selected preset(s)" to export all of them to my Desktop. Then I imported them into GR6 via the "File->Import..." menu entry from the Desktop. That made them show up in the GR6 browser.

    If those presets are already in GR5 on your computer you could try just exporting them, but I'm not sure if that is sufficient. If not, then you have to first remove them from Guitar Rig 5, but make sure to have a backup copy of them somewhere! Users presets for Guitar Rig 5 on Mac are stored in Macintosh HD > Users > *your username* > Documents > Native Instruments > Guitar Rig 5 > Sounds.

    I hope this helps, let me know if you have any other questions.


    Cheers,

    Eddie

Answers

  • Eddie_NI
    Eddie_NI Product Team Posts: 35 mod

    Hi rcelestin,

    sorry that you are having trouble with Guitar Rig 6. I'm not sure what's going wrong, we have not seen this issue during testing. Could you please send us two of the presets that don't import correctly so we can have a look?

    Cheers,

    Eddie

  • rcelestin
    rcelestin Member Posts: 4 Sine

    Thanks for your answer.

    Actually, none of the presets are showing up now, my "USER" presets are not loaded.

    Pleas find attached 2 of them

    Thanks a lot !

  • Eddie_NI
    Eddie_NI Product Team Posts: 35 mod

    I can't seem to find the attached files 😕 Could you please attach them again or send them as a direct message to me?

  • rcelestin
    rcelestin Member Posts: 4 Sine

    Hi!

    I had to zip them in order to attached them.

    A precision regarding my problem : my presets came from GR5 initially. I succeed on importing presets from GR5 to GR6 when I purchased the GR6 upgrade 2 months ago. But I found 3 days ago that 1 preset was missing when I switched from 5 to 6. I reseted the library on GR6 and imported once again all my presets thinking it was a bug, but now all my presets are missing.

    Please find attached 2 of the presets. Thanks a lot !


    presets.zip

    Uploaded 9:10 am11.33 KB

  • Eddie_NI
    Eddie_NI Product Team Posts: 35 mod
    Answer ✓

    Hi rcelestin,

    I had a look at your presets and found an issue. There is a requirement in Guitar Rig 6 that the filename of a preset has to match the preset name that is stored inside the file, if it should be imported. (Various reasons for that). And that is usually the case for all presets. Unless they have been corrupted, maybe during copying or altered manually.

    The presets you sent me don't meet that requirement.

    But I did find a workaround to get your files imported into GR6. I imported them into GR5 via the "File->Import Preset" menu entry (you can also just drag&drop them into the GR5 browser). Then I used the right-click "Export selected preset(s)" to export all of them to my Desktop. Then I imported them into GR6 via the "File->Import..." menu entry from the Desktop. That made them show up in the GR6 browser.

    If those presets are already in GR5 on your computer you could try just exporting them, but I'm not sure if that is sufficient. If not, then you have to first remove them from Guitar Rig 5, but make sure to have a backup copy of them somewhere! Users presets for Guitar Rig 5 on Mac are stored in Macintosh HD > Users > *your username* > Documents > Native Instruments > Guitar Rig 5 > Sounds.

    I hope this helps, let me know if you have any other questions.


    Cheers,

    Eddie

  • rcelestin
    rcelestin Member Posts: 4 Sine

    Thanks it worked!

    What I did wrong initially: I renamed my presets in the MacOS, and not within GR6, so it caused the presets to be not displayed while in GR6.

    What I did then : I went back to GR5 on my old comp. (Windows Vista), I renamed my presets within GR5, I exported them, then I imported them on my Mac within GR6. Then I worked as expected.

    Thanks a lot !

  • bacohen8
    bacohen8 Member Posts: 2 Noise

    I am having a similar issue. I have many many older presets that when imported do not show up. Infact the uSER DESIGATION DOES NOT EVEN SHOW UP. Using windows 11 in my new PC

    Here are three samples. Can you test them?

  • bacohen8
    bacohen8 Member Posts: 2 Noise

    Hi, I realized that these presets are pre GR5. I was attempting to import the original files from years ago. I installed GR5 on the PC imported the ones I really use. Shut GR5 down and opened GR6 and did the import! Perfect!!

Back To Top