How can I fix kit plug-ins not loading?

SamiR
SamiR Member Posts: 3 Noise
edited April 22 in Komplete Kontrol

In Komplete Kontrol, and when using ableton, not a single kit from any pack will load, Solar Breeze, Lilac, Velvet Lounge, etc. Drum lab plug-ins work, but nothing with the word "kit" works.

I've already tried following this tutorial: https://tinyurl.com/bxkh3thp But nothing changed, and the same error keeps appearing. I am at a loss here.

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw
    edited April 15

    if They are not loading in KK then you are trying to load Battery Kits and they load inside the Battery Plugin. If you do not own Battery you will get that error message and those expansion kits are unusable. Drum Lab is a Kontakt Library and loads inside the Kontakt Plugin it is not its own plugin. I assume you either have the Kontakt Player or full version installed, so NI Kontakt libraries will work.

  • SamiR
    SamiR Member Posts: 3 Noise
    edited April 16

    Thank you for your input! I'm not sure if I have Battery Kits, but why would all those kit sounds be present in KK if they're not usable? And are you saying I need to buy additional software to use the things that came with my current software? Also, it's every single plugin with kit in the name, so...could it be that not a single "kit" plugin downloaded through my software will work without this "Battery" software? That just doesn't seem right.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw

    the expansions (Like Velvet Lounge etc) include Maschine Kits (not usable in KK) , Battery Kits (only usable in Kk if you own Battery) and presets for synths like Massive, and Monarch etc. all the samples and loops used to create the Kit presets are included and can be used in any DAW (like Ableton) (again, the kits are not individual “Plugins” but just NKS presets)

    here is a video on the subject!!

    https://youtu.be/DoJI1gG2JH0

  • SamiR
    SamiR Member Posts: 3 Noise

    Thank you, Blindeddie, you were correct! Super relieved, but also a bit frustrated. I don't really understand why all those kits and their sample sounds would be included in the software that came with the hardware/software I purchased, but not be usable and not clearly state why they weren't usable. It really looked like a system error, not super cool of NI. Thank you though!

Back To Top