How do you make Kontakt play STACCATO notes (NOOB ALERT!)

Chrisulrich
Chrisulrich Member Posts: 37 Member

Dear Anyone.

I've got a legit Kontakt 6 (though it's been JBRIDGED for my antique 32-bit DAW, it was bought legit. though!) and downloaded the legit. free Project Pegasus pads/instruments collection and I'm still trying to learn about Kontakt so I HOPE this is obvious to you guys....

Kept getting weird buildups of sound in my pieces using Pegasus. Analysed it and discovered they were happening - I use notation software - when I was using staccato and shorter notes (like 8ths or anything below that, 16ths for example.) Spent a painstaking few hours analyzing why - and discovered Kontakt don't seem able to play PART of a sample. If you're using a note length that's shorter than the instrument's sample length, it'll still play the whole sample length. Which means, for instance, you can't use an arpeggiator plug-in with Kontakt sounds because you immediately get mega-buildup!

Have I just struck unlucky with Project Pegasus or is this a Kontakt bug? If there's a setting to make Kontakt able to play short notes, could someone please tell me what it is (including what menus to find the instructions in, please, am still very much a learner!)

Yours hopefully

Chris, who's got 2 more dumbass questions but would love to get this one answered first!

Comments

  • Triggi
    Triggi Member Posts: 48 Helper

    Hi ChrisUlrich,

    i've to be short now but if there is something like an amp envelope with attac, decay, sustain and release ( depends on instrument in kontakt), then you can shorten the notes by reducing the release, try sustain and decay too.

    Have a good shape!

  • Chrisulrich
    Chrisulrich Member Posts: 37 Member

    Dear Triggi.

    Yup - shorten the sample loop. Tried that. Thing IS - because it's not now hitting the end of its sample - where the perfectly tailored fade in/fade out is, you get a click like a castanet. You can try this - if you physically shorten the sample so it's playing staccato, it can't do long notes any more because. It hits. The end. Of the new length sample. And fades out. And back in again. Like these sentences!


    Thing IS - I've got the SFZ+ soundfont player. Soundfonts use samples too - and that plays staccato notes just fine, as do my other VSTs using samples. It's just Kontakt! Beeg brand, beeg company and they can't get staccatos right?


    Yours puzzledly - I'm gonna carry on investigating this -


    Chris

  • stephen24
    stephen24 Member Posts: 252 Advisor

    Start with the basics. Spend 20 mins or so boning up on the MIDI protocol (how devices communicate with MIDI messages.) You'll quickly learn about note-off messages. Then you can graduate on to envelopes etc and what they do. There's lots to learn.

    Welcome and good luck!

  • Chrisulrich
    Chrisulrich Member Posts: 37 Member

    Dear Stephen 24 et al.

    I know about note-off messages. Thing IS - Kontakt doesn't seem to have heard of 'em! It's not my notation DAW - everything else I've got plays note-on-note-off fine - if it's a short note or a long note they play the sound long and short perfectly (unless of course it's a blippy, staccato sound not designed to play long!)

    The ONLY thing I've got that can't do note-on-note-off is Kontakt. Which is supposed to be the Industry Standard Sampler. Yes I can shorten the length of sample it plays so it does short notes - but then it can't do long notes unless I have 2 instances of the same instrument in Kontakt, one set up for short notes, one set up for long notes. And because the short note one isn't hitting the designed fade-out end of the sample, it clicks like castanets.

    Surely Kontakt can't be so badly designed that it can't just stop playing a note, it has to get to the end of its sample regardless? It's got another ridiculous bug in it too, if this is indeed one - the other one I've found's hilarious AND exasperating!

    But I want to - hopefully - find a way out of this one first. Everything else can just stop playing a note. Why can't Kontakt?

    Yours puzzledly

    Chris.

  • stephen24
    stephen24 Member Posts: 252 Advisor

    Your samples have probably been programmed to ignore notes-off. Look in the Wave Editor - it'll say "one-shot". Change this to "on release". (You can batch-do this - click on the Options (gear) button in the Wave Editor.)

    (leave the sample-end and envelope alone!)

Back To Top