Something went wrong/low power

Tiscot
Tiscot Member Posts: 3 Newcomer
edited December 2023 in Komplete Kontrol

I’m having the seemingly common windows based S88 issues I’m reading around the forum (low power message 90% of time, then something went wrong occasionally).


Its my sons’ Xmas present so time is of the essence…

I followed the instructions to the letter for install and it’s not picking up the keyboard on the updater now after the first update was unsuccessful.


Ive contacted support but can anyone define a working Win 10 setup and cable manufacturers I can model on rather than me likely trialling various usb c cables/adapters at expense and time. The 4 cables I have work with every other device I have for reference.


Thanks

«13

Comments

  • PoorFellow
    PoorFellow Moderator Posts: 1,549 mod

    If the computer is "not picking up the keyboard on the updater now after the first update was unsuccessful" then if the keyboard is otherwise not responsive either then you might have to get in contact with hardware support. Generally the S88 MK3 appear to need a USB-C PSU attached when updating. Also sometimes connection problems can be resolved by using a self-powered USB-C hub and/or better cables.

    You need to use both a power adapter and maybe another cable. Apparently the passive version of Thunderbolt 4 cables are the best but also rather expensive ! (I am not in a position to guarantee that even the best of cables will solve your problems)

    For PSU try taking a look at my post over here and read the discussion to end , these are just meant as examples and I can not vouch for any product mentioned so any purchase decision made is on your own responsibility ! (as I wrote then all mentioned ought to be more than adequate with respect to how much current they deliver) : https://community.native-instruments.com/discussion/comment/100518/#Comment_100518

    Unless one buys an item of a brand name that one trusts then it's always sort of a gamble when choosing something. Also I noticed that the PSU the other person choose is down to £ 9.99 but I still can't tell if the quality is OK !

  • Tiscot
    Tiscot Member Posts: 3 Newcomer

    I've bought a new USB C cable and I'm still unable to update firmware as it keeps coming up with 'failed to boot firmware' message. Also no response from customer support ticket yet...

  • Matthew_NI
    Matthew_NI Product Team Posts: 682 mod

    Have you updated to the latest Windows update?

    Microsoft have just published the driver that resolves the S88 issues we were seeing on Windows, so this would be my first suggestion.

    Secondly, it sounds like the USB port is not providing enough power to the S88. For situations like this, the second USB-C input is provided - and this must be connected to a wall charger (e.g. a commonplace USB-C smartphone charger). When appropriately powered, the existing USB-C cable and data connection can function, as the device is now receiving enough power.

  • Stef06
    Stef06 Member Posts: 1 Newcomer

    Bonjour, Je rencontre exactement le même problème que Tiscot.

    Avez-vous résolu le problème.

    Merci pour vos retours

  • Carpengui
    Carpengui Member Posts: 15 Member
    edited February 14

    @Matthew_NI Would it be too much trouble just to tell us all EXACTLY what the power supply requirements are for the new S-series boards??? I've already been through every charger cube kicking around in desk drawers (4 of them) and none of them seem to be enough. I have a couple of "Power Delivery" devices now on order, but I'm just guessing/hoping it might be enough since NI won't tell us. I would expect that should be front-and-center on a card that says "Read Me First" in the box.

    So is it 20W? 30W? 40W? Does it vary depending on the model? This is a common problem that needs a definitive answer! [Edit: by the way: this has nothing whatsoever to do with Windows drivers... and right now there's no way to do a firmware update either since I'm locked on 'Low Power']

  • Hywel
    Hywel Member Posts: 21 Member

    I come here every once in a while to catch up on Kontrol S-Series Mk3 and KK issues - the power or lack of power to particularly the S88 keyboard comes up with monotonous regularity BUT I have NOT ONCE heard anybody from NI stating what wattage it specifically requires... sorry for not being more helpful.

  • Sunborn
    Sunborn Member Posts: 2,134 Expert
    edited February 14
  • reffahcs
    reffahcs Member Posts: 708 Pro

    I had issues with my Mac Studio when I first purchased my keyboard. It would only work with one particular USB-C cable, but I finally bought a powered USB-C hub and now it works perfectly fine with the factory cable, no additional USB-C power required. Just make sure your USB-C hub can provide power and data over the same port.

    For reference I'm using this one from Amazon:

    https://www.amazon.com/Rosonway-Individual-Switches-Aluminum-RSH-A107C/dp/B0BXRY4QZ5

  • Carpengui
    Carpengui Member Posts: 15 Member
    edited February 14

    @Sunborn While I appreciate your assistance (seriously, I do -- though why is that buried on page 75??), I can testify that 7.5W appears to be completely insufficient for the task.

    I've been trying multiple power sources in the 2-2.4 Amp range (at 5V, this makes 10-12 watts) on two different S88's to date and this has proven to be unhelpful thus far. I will also note that that NI has referred to the use of "commonplace" USB chargers (see above)... a category that 7.5W of output would certainly fall into, but again... it's not proven effective.

    A 20W solution is en route.

  • Matthew_NI
    Matthew_NI Product Team Posts: 682 mod

    Is it possible the charger has misleading specs?

    If you've the host connection to computer via the main USB-C input/output, and the power connection from wall to keyboard via the auxiliary USB-C input, then a charger compatible with those specs would power the S88 no problem. most standard chargers, such as smartphone chargers, fall into this category.

  • Carpengui
    Carpengui Member Posts: 15 Member

    @Matthew_NI As I suggested above, I've tried 4 different charger cubes to date. I just bought one that is supposed to provide 20-25W. Will try that and report back.

  • Carpengui
    Carpengui Member Posts: 15 Member
    edited February 15

    @Matthew_NI Reporting back: a dedicated 20-25W USB-C power supply (apparently it's either 20W or 25W, depending on ... something) does give me enough power to run this board.

    Now the problem is that my Windows 10 O/S is giving me a "Device Not Recognized" error. I have run the USB Driver installer (to no avail), but the Firmware updater can't see the board since Windows doesn't know what it is. For the record, I am using Windows 10, Build 19045 (10.0.19405), and it worked perfectly with my prior mk2 S88.

    The Device Manager reports this: "Windows has stopped this device because it has reported problems. (Code 43) ... A request for the USB device descriptor failed."

    *sigh*

  • Sunborn
    Sunborn Member Posts: 2,134 Expert
    edited February 15

    It seems to me that you have a USB "power delivery" issue.

    Please try this:

    First go to your Device Manager, go to "View" and click "Show hidden devices".

    Then go to "Universal serial bus controllers" and uninstall all devices named as:

    "Unknown USB Device (Device Descriptor Request Failed)".

    What is the "Unknown USB Device (Device Descriptor Request Failed)" error: The USB device descriptor is used to store information for USB drives and it is responsible for recognizing different USB devices. If it fails to work properly on Windows 10 or Windows 11, the USB drive cannot be recognized by the operating system and you may get errors like code 43. The USB device that reports error code 43 cannot communicate properly with the computer, as there might be a connection issue. In some cases USB ports on the computer might be damaged, faulty, or not functioning correctly, so if this continues, it is a good idea to try different ports!


    Note that: as long as you keep the above "Unknown" devices, the original ones, will either not work at all, either their behavior will be problematic.


    Then go to Control Panel --> "Power Options" and choose "High Performance" plan.

    Then click the Advanced options and disable the "USB selective suspend" on both, Battery and Plugged In.

    On many cases, operating system will put the USB port in low-power mode if the USB selective suspend setting is enabled! If so, the USB drive connecting to this port won't be able to work normally and cause the "USB device_descriptor_failure problem". To solve the problem disable this feature.


    This is a potentially "catastrophic" Windows option for music related hardware! Microsoft has it as default for a simple reason: Their default options were meant for the average customer, not for the musician. And musicians (and generally artists) are less than 2% of the total Windows users...

    Anyway, after that, restart your PC and try again. Let Windows to boot completely and all your start-up programs to start, before you plug your device.

    I can't guarantee 100% that this will work, but at least you will get rid of all those messages from your Device manager and all the false drivers...

  • Carpengui
    Carpengui Member Posts: 15 Member

    @Sunborn Full marks for the response -- the effort is definitely appreciated. There's also the hilarious irony of having a 'power delivery' problem right after having resolved the board's power supply problem.

    Unfortunately, that procedure did not change the state of affairs here: I'm still getting the same issue: Device Descriptor Request Failed.

    I am wondering if the installation of the prior version of this keyboard (the s88 mk2) might somehow be interfering with the recognition of the new mk3. That said, I don't know how to determine which one of the myriad USB devices listed would be the ghost of the mk2 -- probably one of the 'USB Composite Device' entries (there are currently 13 of them that are not plugged in within the hidden list)??

    Also done a bit of additional research into the problem... not a lot of support out there for this issue. Short of reinstalling Windows 10 (not really an option), I wonder if there's much else that can be done here beyond the work already done.

    (I also apologize that I feel like I've hijacked that O.P... but I am hoping this gets some useful info on the board for others)

  • Sunborn
    Sunborn Member Posts: 2,134 Expert
    edited February 15

    ok,

    I am wondering if the installation of the prior version of this keyboard (the s88 mk2) might somehow be interfering with the recognition of the new mk3.

    Nope. Those are exist (or existed) as "NI USB Devices".

    I don't know how to determine which one of the myriad USB devices listed would be the ghost of the mk2 -- probably one of the 'USB Composite Device' entries (there are currently 13 of them that are not plugged in within the hidden list)??

    -Just remove them all!

    A USB Composite Device is a peripheral device that supports more than one device class. Many different devices can be implemented as composite devices. Basically it is a generic Microsoft "device holder". If it finds devices, it installed automatically, nothing to worry of.

    Most of them are for detached hard drives or usb stick, or older devices that does not exist anymore. If you plug again any of those devices a USB Composite Device will be installed automatically in the background. In most cases, it will be a new one, so those "ghosts" will remain...

    -Or, if you have patience, go one by one, open them, go to Details and check the property named as "Bus reported device description" to see what was connected there.

    Basically it is only one SK49 MK2 device, connected to one USB Composite Device, and then this device it splits in 3 sub-devices as you can see above, in "NI USB Devices".

    Conclusion: Your prior version of this keyboard (the s88 mk2) has nothing to do. Since it is not plugged, it can not consume any power. However, it is a very good idea to remove whatever relics remains.

    Yet, I'm afraid that all the above probably will not solve your problem and unfortunately i don't have a MK3 keyboard to test it further. 😯

Back To Top