Only Snapshots Are Showing In The KK Browser After Reinstalls, .nki Files Are Missing

FosterMoose
FosterMoose Member Posts: 12 Member

Had a strange thing happen a couple days ago. I was doing year-end sample library cleanup/maintenance and discovered that some NI libraries needed re-installing. After completing the re-installs the KK browser now only shows the library's snapshots, but not the .nki files. The snaps load fine and if I manually find and select the .nki file it works. Further, when I went back to the old library version to see if the .nki files appeared, they didn't! Even more curious, both the snaps and the .nki files show up in the Kontakt browser after re-installing.

I've normally been able to figure out these kinds of issues, but this time I'm truly stumped. Anyone know why this is happening?

I'm on an Intel MacPro OS 13.6.3 and still using KK 2.9.4 for a number of reasons, but I can't imagine that's the culprit. Also running Kontakt 7.7.3.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    Did you do the reinstall through Native Access? Do these libraries now show as installed in Native Access? If you open Kontakt in standalone, are all your libraries showing and can you load them?

    If it's only an issue with Komplete Kontrol, please try resetting the database:

    Reinitialize the KOMPLETE KONTROL Database

    1. Go to the following location on your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
    3. Note: The User Library folder is hidden. See this article for instructions to access hidden macOS folders.
    4. Search through the Native Instruments folder at this location to find the KOMPLETE KONTROL folder.
    5. Delete only the KOMPLETE KONTROL folder found here.
    6. Note: Deleting other NI product folders could result in unexpected behavior with other applications.
    7. Reboot your computer and reopen the KOMPLETE KONTROL software to check that the issue has been resolved.


  • FosterMoose
    FosterMoose Member Posts: 12 Member

    Thanks for responding!

    Yes, I installed through Native Access (3.8.0) and all of the libraries show as installed. They are also showing in full in Kontakt (7.7.3).

    I apologize for not mentioning that I did full database resets of both Komplete Kontrol and Kontakt before starting this thread. I make it a point to never ask for help unless I've tried every granule of troubleshooting I can find. I also did normal reinstalls, full uninstall/reinstalls and batch resaves. The .nkc, .ninct and .nkr files were never touched or modified. Rebuilding the favorites.db and Service Center pal.db did nothing. And as far as I can see from comparing NI resource files in Time Machine, everything is identical in contents, name and size. I've been using NI products heavily for over 20 years and thoroughly understand how all the apps and files inter-relate. That's why I'm stumped. Everything seems to be in order, but it's still not working.

    The only thing I can think of is that it has something to do with factory tagging being corrupted somehow, but that's dev-side stuff and I don't want to monkey with it.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @FosterMoose I've contacted you by email regarding this issue, my colleagues will need to check it out.

  • FosterMoose
    FosterMoose Member Posts: 12 Member

    Thank you! I really appreciate it.

Back To Top