GR7 selecting a preset from a VST host

dimichelec
dimichelec Member Posts: 6 Newcomer

Hi,

I'm using GR7 as a plugin in a VST host (Element/Kushview) in a live performance context. If I select a factory preset, GR7 doesn't reset the rack first and appears to be adding the selected preset components/parameter values to the state of the GR7 rack before the new preset was selected.

I looked thru the docs and settings and can't seem to find anything relevant that would help.

Thanks!

Comments

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Hi,

    I just tried Element 0.46.6 on Windows and Guitar Rig loads presets just fine inside of it. For example I can load the first factory preset ("Tight & Chunky") and then load the second one ("Lofi Delight") all the components from the first one are removed and then the ones from the second one get inserted.

    What are your steps to get to the problem? Can you maybe provide a screen recording?

  • dimichelec
    dimichelec Member Posts: 6 Newcomer

    Thanks @Eddie_NI, I think I may have found out what's happening. The steps are, load a factory preset, "Michael's Delight" in my case. Then using the right-click menu (I'm on a Windows system), "Add Preset" and name it "Michael's Delight". I'm doing this to have a few select presets close at hand, which is probably not a good way to get what I'm after. Then, I select another factory preset, "Super Gary" in this case, Add Preset "Super Gary". So, I now have just two presets (Element's presets, as opposed to GR7's presets, which I think is the root of my problem) "Michael's Delight" and "Super Gary". If I now select Michael's Delight from the short list in the right-click menu, I get a sound that's not Michael's Delight. The stack of components appear to be proper, but I'm guessing not all parameter values are correct. I'll dig into that later and post my results.

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    So you are not talking about presets inside of Guitar Rig, right. I have to try out the presents that are stored by this Element right-click menu.

  • dimichelec
    dimichelec Member Posts: 6 Newcomer

    That's right. I thought it may be related to Guitar Rig switching to the preset as requested from Element. After testing this for a bit, I think it's an issue with the way Element is managing its presets. I get the failure I stated above if I add Element presets too quickly. For example, I select Michael's Delight from the Guitar Rig UI, right-click on the Element Guitar Rig plugin and add a preset named "md". Then select Super Gary from the Guitar Rig UI, right-click the Element plugin and add preset "sg". When I do this quickly, Element saves "sg" as a mashup of Michael's Delight and Super Gary, probably saving whatever Guitar Rig parameter values are during the transition. If I wait for Element to catch-up it works fine.

    I consider this closed. Thanks for your patience.

Back To Top