Plug-in for device "KOMPLETE KONTROL S-SERIES" is missing - Logic alert

KasperFischer
KasperFischer Member Posts: 9 Newcomer

Hi!

Just updated my Mac Mini M1 to Sonoma. Also updated Logic pro to vers. 10.8.

I get this alert when opening (see picture)

I have been reinstalling Komplete Kontrol vers. 3 - Rescanning librarys

Any good ideas?


Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,713 mod
    Answer ✓

    @KasperFischer Try to close Logic and delete this file:

    Macintosh HD/Users/username/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:


«1

Answers

  • Milos
    Milos Member Posts: 681 Advisor

    Hmm...

    Maybe you can try this:

    To make a custop desktop folder for the NI plugins, then go to the File Managemwnt inside NA and then change the VST3 location to that folder.

    I tried that for my NI plugins and it worked.

    Hope it can help you as well.

  • Kymeia
    Kymeia Member Posts: 2,775 Expert

    Do you know which plugin it is referring to as missing or is it saying Komplete Kontrol itself is missing?

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    Seems like all NI plug-ins.

    Its possible to play other Plug-ins in logic on the controller

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    Thanks Milos! I'll try this...

  • Milos
    Milos Member Posts: 681 Advisor

    No problem.

    Have a good day!

  • Kymeia
    Kymeia Member Posts: 2,775 Expert
    edited November 21

    No please don't - on Mac the VST3 location is fixed, this could cause all sorts of problems, plugins should not be run from the desktop anyway


    Also is it VST3 problems that have the problem or AU? are you able to load Komplete Kontrol and then getting the error message (in which case it could be a VST issue), or are you not able to load Komplete Kontrol or any NI plugin directly from the plugin menu (in which case it is an AU issue)

  • Milos
    Milos Member Posts: 681 Advisor

    Well, if my advice doesn't work, you can try Kymeia's.

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    I cant load any plug-in.

    I can see all the plug-ins in my browserwindow and I can hear the preview, but when I try to load it fails...

  • Kymeia
    Kymeia Member Posts: 2,775 Expert

    OK so you can load Komplete Kontrol (otherwise you wouldn't hear the preview)

    Have you tried running it in standalone and rescanning all plugins? Also check the paths to VST3 plugins are there in KK settings (and also are you trying to load any that are VST2? KK no longer adds the path to those by default)

  • Kymeia
    Kymeia Member Posts: 2,775 Expert
    edited November 21

    Also can you give me some examples of which plugins are not loading?

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    Yes to all your questions ;o)

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    no plug-ins are loading...

  • Kymeia
    Kymeia Member Posts: 2,775 Expert
    edited November 21

    So you are trying to load VST2 plugins as well? a) for that to work firstly you need to add the path to the VST2 folder manually in Komplete Kontrol and rescan plugins - it should do that automatically b) running Logic in Rosetta mode

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    Yes, Path is fixed!

    Logic is running in Rosetta

  • KasperFischer
    KasperFischer Member Posts: 9 Newcomer

    I have to go to a meeting... Thank you, guys!

    I'll get back to this later ;o)

Back To Top