Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

Logic Pro X crashes with new Kontrol S61 Mk3 - Constantly

24

Answers

  • timk
    timk Member Posts: 20 Member

    Hi

    Still getting crashing - sorry. Have sent a couple of videos to the support team showing what happens.

  • timk
    timk Member Posts: 20 Member

    Quick update for anyone following this thread.

    Seems to be a problem with K7 and Sonoma only. So if you’re desperate roll back to Ventura until NI fix the problem, or just use Komplete Kontrol for the time being - that works fine. Both Ventura (K7 or KK) and Sonoma (KK) work best with the input/output set to DAW rather than MAIN.

    If you’re struggling rolling back - I had an awful time just trying to get a bootable Ventura install USB drive kept getting “The bless of the installer disk failed.” Then you need to faff about and turn Full Security off in OSX Recovery settings.

    Anyway the K7 crashing is still with the devs and if I hear more I will post here.

  • Matthew_NI
    Matthew_NI Product Team Posts: 684 mod

    To clarify - is it the case that the problem resolves after that preference file is deleted, and reappears when the preference file reappears?

  • timk
    timk Member Posts: 20 Member
    edited November 2023

    Hi.

    It reoccurs whenever there is a preference file. Even if you delete the file the first track seems to work ok but adding in additional tracks causes the same crashing behaviour.

    This only happens on Sonoma. I rolled back to Ventura and everything works fine.

    So for now I’ll stick with using Komplete Kontrol as the plugin - this also works fine. Then when K7 works on sonoma move to using it natively rather than in the KK Host plugin.

  • ini4
    ini4 Member Posts: 22 Helper

    I am having the same problem. I haven't contacted support, because I really use Kontakt inside of Komplete Kontrol software. When using Kontakt alone, Logic crashes every time. I tried deleting the config file, but the problem comes back. I've noticed that if I delete the config file, I can select the preset in Kontakt via the mouse first, then I can select the next sound from the same product via the S61 mk3. However, if I were to select a preset from a different product, it crashes.

    I'll contact support and send over my info.

  • Matthew_NI
    Matthew_NI Product Team Posts: 684 mod
    edited November 2023

    Some updates.

    We can reproduce this in-house on both Sonoma and Ventura.

    We are in communication with Apple, to clarify whether the fix is on their side, our side, or both.

    Beyond this, I cannot say any more.

  • ini4
    ini4 Member Posts: 22 Helper

    Thanks for the update @Matthew_NI. I suspect the issue might be on Apple's side. Logic crashed for me in a similar way with Arturia's Analog Lab, but I can't recreate it. The Kontakt 7 AU plugin seems to work fine in Ableton Live 11.

  • Matthew_NI
    Matthew_NI Product Team Posts: 684 mod

    To be honest - I'm not sure. It's currently in the "let's collaborate on the investigation" stage of things.

  • timk
    timk Member Posts: 20 Member

    @Matthew_NI if it’s any help I sent a load of videos against my support case of both Sonoma and Ventura installations and the crashes / not crashing.

  • Matthew_NI
    Matthew_NI Product Team Posts: 684 mod

    Yup - it has been. All the support tickets helped with the diagnostics, so thank you if you were part of that.

  • ini4
    ini4 Member Posts: 22 Helper
    edited December 2023

    There is a new Logic Pro update v10.8.1 and so far it seems to have fixed the crashing issue I had with Kontakt 7.

  • timk
    timk Member Posts: 20 Member

    Unfortunately I still get the same crashes in Logic 10.8.1 and Sonoma 14.1.2

    Tried the whole delete the com.apple.logic.pro.cs thing too - but still crashes like clockwork :-)

  • ini4
    ini4 Member Posts: 22 Helper

    Ugh. The issue just came back. Everything seemed for the first couple of hours after installing the update, and now I'm back to using Komplete Kontrol software.

  • Plight
    Plight Member Posts: 7 Newcomer

    Phew, this isn't just me--I have a ticket with logs to try help resolve. For me, this issue affects K7 in Logic, Ableton Suite 11, Cubase 12, stand-alone KK and a couple of other processes. I am providing detail here in case any of this helps/others have the same problem.

    Behaviour: KK crashes intermittently in stand-alone mode after 5-15 minutes use in a way difficult to reproduce (typically switching instruments/presets within instruments). K7 loads, but crashes immediately in Logic when loading certain instruments and crashes during use for instruments that do load. This affects single instruments and multis and the split of what will and won't load can be inconsistent on re-challenge. First-load of instruments has a higher success rate in K7 in Cubase 12 and Ableton Live 11, however, K7 will crash both applications persistently during use in a way that is difficult to reproduce but often though not exclusively caused by loading a new instrument or changing a preset within a loaded instrument. Previews do not play for some instruments on S61 when browsing K7 in DAW. Crash logs show K7 has also crashed AUHostingServiceXPC_arrow and com.apple.audio.InfoHelper.

    Diagnostic Logging: all crash logs point to similar memory errors: EXC_BAD_ACCESS (SIGSEV), EXC_BAD_ACCESS (SIGBUS), EXC_BREAKPOINT (SIGTRAP), EXC_CRASH (SIGABRT). Summary of a sample of logs attached with specific references:

    Hardware: MacBook Pro M1 Max 64GB (Sonoma 14.1.1). Komplete Kontrol MKIII S61 (latest firmware). Samsung T7 (latest firmware + Samsung Magician). Full hardware diagnostics on M1/T7 reveal no faults/issues. I have experienced no other crashes in any other programs.

    Software: Komplete Kontrol 3.0.3, Kontakt 7.7.2, Logic Pro 10.7.9 (trial), Cubase 12.0.6.0 (March 2023 - Silicon), Ableton Live Suite (11.3.13 - Silicon). All software genuine.

    Libraries: all saved on external Samsung T7. Komplete Ultimate 14 (all up-to-date in NI), almost all EW libraries, Waves cloud instruments, Output Exhale, handful of Sound Iron libraries. All libraries genuine.

    Troubleshooting steps: All NI applications/DAWs have full folder access. Versions in stand-alone match DAW versions. I have reinitialised the Kontakt database. I have deleted my user preferences. I have reinstalled Komplete Kontrol and Kontakt 7. I have deleted the Logic cs file. No other crashes or issues taking place with any of my other applications except for Kontakt 7/Komplete Kontrol.

    Next Steps: If it's helpful to dig into behaviour in other DAWs/KK stand-alone mode, I'm happy to help try pinpoint the crashes that are harder to reproduce further if this is of use. If we're in watch-and-wait mode, it would be great to have updates on timing for a hot-fix as itching to use my new keyboard!

    Thanks

    Plight

  • Plight
    Plight Member Posts: 7 Newcomer

    I'm going to create a new thread as this one is marked as answered and the issues I'm experiencing are broader than just Logic.

Back To Top