Komplete Kontrol MK3, VST3 Plugin GUI Problems

PhatMonkey Member Posts: 27 Member
edited October 17 in Komplete Kontrol

Several plugins GUI in the new MK3 software update for Komplete do not show correctly, some VST3 are half missing such as LOVE vst by Tracktion, another problem I noticed Arturia Piano V3 its GUI is huge lol.... gee wiz...




  • Matthew_NI
    Matthew_NI Product Team Posts: 421 mod

    If you have a full list, let me know here.

    We test with as many as possible, but the variables are vast. The Arturia plug-in supports resizing I think, so can be made smaller or larger, and KK will follow.

  • mykejb
    mykejb Member Posts: 294 Pro

    Just checked and it does resize ok, it just starts with a huge window the first time it's loaded. Once you've resized it the new size sticks.

    -- Mike

  • Vagus
    Vagus Member Posts: 351 Pro

    Adding to this, I had problems with Audio Damage products- and this was a windows scaling issue. When I went to advanced options on the properties tab of KK, I turned off app specific scaling, and they worked fine.

    Only one plugin I have, has an issue, which is Noisy from Expressive E - KK scans it, but does not show in plugins, so can't be loaded.

  • PhatMonkey
    PhatMonkey Member Posts: 27 Member

    The Piano I manged to resize, but the Dawesome (Tracktion) LOVE vst 3 wont resize at all, worked perfect in the previous version of Kontrol

  • Vagus
    Vagus Member Posts: 351 Pro

    This is the issue I had with Abyss - and was fixed when turning off per app scaling in HiDPI settings on the app in Windows.

    Right click on KK, Change HiDPI settings, click override HiDPI scaling behavior, and select "App".

    This should fix the issue.

    Example, but change it to App, not system:

  • PhatMonkey
    PhatMonkey Member Posts: 27 Member
    edited October 17

    That worked, great thanks :) UPDATE: Spoke too soon, it worked for the LOVE VST3 but now the Arturia Piano is small and the clicking of buttons on the gui is miles off, for example if I was clicking C3 it would register as C1 on the piano lol... Seems to be one or the other.... I am going to experiment with Patchwork, see if I can bring LOVE into Kontrol using that...

  • Kymeia
    Kymeia Member Posts: 2,795 Expert

    Dawsome plugins seem to have a gui problem on some systems, maybe a Windows graphics thing as they are fine on my Mac

  • JesterMgee
    JesterMgee Member Posts: 2,278 Expert

    There are also issues (still) with many plugins like Korg, Cherry Audio when used in Ableton Live and likely some other daws where the display is completely black (both PC and Mac). THis was an issue also in KK 2.9 for VST3 version of KK but VST2 is fine.

    I reported this a year ago and was told they believed they knew the problem that Ableton does not report something correctly and would look into but still no solution. Maschine is fine in how it works, just KK is the issue which is kind of frustrating to still have it in the latest version.

  • PhatMonkey
    PhatMonkey Member Posts: 27 Member

    My work around seems to work, loaded it in Patchwork instead, in fact even loaded the Arturia Piano V3 in it also within Komplete then saved the preset, less hassle :D

  • apc83
    apc83 Member Posts: 2 Newcomer

    Et ça arrête le support de MK1, et les bugs d’affichage VST 3 ne sont toujours pas corrigés...

  • gperroud
    gperroud Member Posts: 6 Newcomer
    edited November 3

    With my Komplete Kontrol MK2 I was able to open Spectrasonics products like Keyscape, Omnisphere, and also Arturia Analog Lab V. With my brand new and updated Kontrol MK3 they don't open... how is it possible ? did I forget to install smthg? with the same MacMini M1 btw, nothing has changed, I just installed the new MK3 and everything is correctly updated in Native Access. Or sometimes it works, and sometimes not.. crazy..

  • Kymeia
    Kymeia Member Posts: 2,795 Expert

    These are all plugins that don’t have NKS versions themselves but do have third party created NKS libraries from Freelance Soundlabs so it sounds like either you haven’t installed those or need to rebuild the database (as KK3 has a different database to keep it separate from KK2)

Back To Top