S61 Mk3 bricked by firmware update

SteveC0101 Member Posts: 4 Newcomer
edited October 21 in Komplete Kontrol

Hi all,

Just received my S61 Mk3 from Andertons today. Downloaded and ran Native Access update and the firmware updater as per the list of instructions on the NI site. The keyboard was saying "updating.. " etc when suddenly the updater app gives me a message that the update has failed. At this point the keyboard reset itself and now wont turn on. Nothing, no lights or screen activity.

Is there a hard reset button combo to re-install the old firmware?

If it is fatal, should I go through Andertons or NI to get it resolved?




  • PoorFellow
    PoorFellow Member Posts: 1,045 Guru
    edited October 21

    Problem most likely is that you have been sent a keyboard that , judging from a recent post by another user, is not compatible with the firmware update. In fact anybody receiving the keyboard before October 17 has been sent the keyboard by a mistake or by negligence !

    Where to return the keyboard to you will have to ask N.I. support : https://support.native-instruments.com/hc/en-us/categories/360000053657-Account-Order

  • SteveC0101
    SteveC0101 Member Posts: 4 Newcomer

    Thanks for the info Poorfellow.

    I've started a support ticket. Any idea of how long they usually take to respond? It's my first experience of NI hardware and for a £750 purchase I'm not that impressed! I'll give Andertons a call today too to make sure I'm covered in case of a return to them..

    Thanks again.

  • PoorFellow
    PoorFellow Member Posts: 1,045 Guru
    edited October 14

    Support response time varies depending on load and can take from a day to a week (or more ?). But you ought to have received a ticket confirmation and if it takes too long time then kindly update your ticket politely to try to get their attention. N.I. apparently have many customers and handle all sorts of support requests in high numbers so it even happens that a ticket is lost or buried , but you still need to be patient. At least give them a week and if they do not respond then call a forum admin and have them check up on it. The usually omnipresent forum admin Jeremy however apparently is off for I don't know , maybe a month , but there ought to be others then...

  • SteveC0101
    SteveC0101 Member Posts: 4 Newcomer

    To be fair, I don't really have that level of patience with a £750 paperweight sitting in my studio. I spoke with Andertons and they reckon NI will probably have them replace the unit anyway, so I'll start that process on Monday. That'll teach me to update any firmware on Friday the 13th! :D Thanks again for your help.

  • John L
    John L Member Posts: 1 Newcomer

    I have exact the same problem and I am very dissapointed with the lack of good support. I have spent many thousands of euros on kontakt libaries and love them.


  • superwotan
    superwotan Member Posts: 25 Member

    I just want my money back 1299 EUR and they can come and pick up the fantastic S88- MK3 that looks so pretty with all the fancy light, knobs, wheels... the only problem is: it doesn't work.

    So I guess I wait a year, read the community post then, and maybe when they have fixed the issues, I will give it another try. But for now I am superdisapointed.

    and you can't even get in touch with them directly.

  • PoorFellow
    PoorFellow Member Posts: 1,045 Guru
    edited October 21

    I understand your frustration and I would not have been happy either if I were in your situation. It appears as if N.I. with respect to firmware updating have not done enough tests with enough systems prior to shipping which of course is not good. So you will have to choose if you will give them a chance to amend their fault and your experience or just to get something else !

    It's not an optimal customer experience that's for sure !

  • Martin_NI
    Martin_NI Product Team Posts: 22 mod

    Hey @SteveC0101,

    Here are a couple of things you can try to get your keyboard setup

    • Ensure your USB-C cable is plugged into the "HOST" USB-C port on the keyboard
    • Try a different USB-C port on your computer.
    • Try a USB-C hub plugged into your computer's USB-C port. Ensure you use a data port on the USB C hub as some only do USB-C power pass-through.
  • SteveC0101
    SteveC0101 Member Posts: 4 Newcomer

    Hi Martin,

    No need - I've already had the defective unit replaced by Andertons (big shout-out to the team there - super quick response). The original unit was totally bricked by the firmware update. No combination of PSUs/Cables or different ports or computers would bring it life. I believe NI support have asked Andertons to forward the unit to them to investigate. I'll definitely wait a month to update after any future firmware release.

    The replacement did update firmware without a problem, however now I'm getting a "Loading Issue. Could not load Plug-in." message. I've re-scanned without success.. Is there guidance specific to Native Access 2 and the Mk3 ecosystem? All the existing guidance is for the old hardware/software.



  • Martin_NI
    Martin_NI Product Team Posts: 22 mod

    Hey @SteveC0101

    The issue could be caused by one of the following.

    • You need to run Komplete Kontrol 3 in standalone mode and do a rescan. this needs to be done once to build your plug-in list before using Komplete Kontrol 3 as a plug-in.
    • The plug-in you are loading is no longer in the location where the scan found the plug-in. I.e. an external drive has been unplugged where the plug-in is installed.
    • I think you are on Windows from your profile but for others looking at the thread. On Apple Silicon, this can happen if the plug-in you are trying to use only works in Rosetta mode and you are running your DAW in native Apple Silicon mode.

    I hope that helps.

  • threebeerhonesty
    threebeerhonesty Member Posts: 1 Newcomer

    I just had this same issue with a unit received yesterday October 22. Firmware update bricked the unit exactly as described above.

  • Chris Cologne
    Chris Cologne Member Posts: 6 Newcomer

    The same goes for me.

    I have tried it on different devices (all Windows 11). With the original cable i do not get a connection. Used another cable, the firmware updater found it but ended in an error. Now the keyboard shows "Looks like something went wrong".

    Tried everything the NI support told me.

    Tried to start it again 5 times but the keyboard is not resetting. Only on the first computer the keyboard can be found in the updater but it shows firmware and when i try to update it i get an error -2.

    Tried it with other Cables. USB-C, USB-A with power supply....

    Other PCs or a Windows Guest account can not connect to the keyboard.

    I contacted the NI hardware support and hope they can help me.

  • AMN
    AMN Member Posts: 2 Newcomer

    Expereancing a Similar Problem with my S88. When Trying to Update The Firmware i got an Error Saying that the Keyboard Failed to boot into firmware update mode and i have to powercycle the unit and try again. i tried all the suggestet fixes on the service site but nothing seems to work. It just starts the update and then loads infinatley. Im really frustrated. just submitted a support ticket but god knows how long thats gonna take. if anyone expereanced the same issue and found a fix then please tell me how!!

    it really sucks when you spend so much money on a piece of Hardware that doesnt even work properly.

  • Chris Cologne
    Chris Cologne Member Posts: 6 Newcomer

    I have now tried it on a colleague's Mac and was able to update successfully. No problems there.

    Hope it will work on Windows as well. I can give you an update in the evenying.

  • rthree
    rthree Member Posts: 2 Newcomer

    Yikes, I am receiving mine today and now I’m paranoid to do anything. Wonder if certain serial #’s are impacted or if it’s the whole batch

Back To Top