Guitar Rig 6 crashes my Focusrite Asio USB driver

awo Member Posts: 3 Newcomer

When I open Guitar Rig 6, I can hear the guitar input in the software, but after a few seconds, if I start playing or change the preset - the USB driver crashes. I see the audio interface disconnecting for a few seconds and after that everything recovers on Windows (eg. if I am also playing sound of spotify - I hear it come back after a few seconds), but Guitar Rig is than messed up and I cannot use the audio interface anymore in Guitar Rig.

When I restart Guitar Rig I must select the usb driver again in the audio preferences, but then again, after a few seconds the connection to the audio interface crashes again.

I tried

  • removing Asio4All USB driver
  • reinstalling focusrite usb driver
  • resintalling guitar rig
  • Windows is fully patched with the latest updates

nothing helps

I also have Amplitube (Guitar Rig alternative) - which does not have this issue. So I would rule out hardware issues on the audio interface.

Did anyone have the same issue with Guitar Rig and Focusrite Scarlett 4i4? Anyone knows how to solve it?

Best regards

Andy - Belgium


  • Uwe303
    Uwe303 Moderator Posts: 2,539 mod
    edited October 13


    what exact focusrite interface do you use, and I guess with the aso driver? With my focusrite 8i6 it always worked fine without issues for example.

  • awo
    awo Member Posts: 3 Newcomer

    Hi Uwe303,

    I appreciate your reply. I have a Focusrite Scarlett 4i4 3th Gen. Previously, I used a 2i2 2nd Gen, which worked well with GuitarRig. I use the ASO driver from Focusrite.

    I did more tests yesterday and it ran fine for 10, 20 minutes as long as I didn't change anything - in GuitarRig or on the Focusrite (e.g., plugging in headphones would crash it - only with GuitarRig, not when running Ableton Live alone with another Amp Simulator).

    But with my old Focusrite, I never had issues with GuitarRig.

    I hope I get this fixed somehow - I also reach out to focusrite.

  • Uwe303
    Uwe303 Moderator Posts: 2,539 mod

    Even if it's maybe not the issue cause it runs stable with other apps, have you tried another USB port? And asking also focusrite is a good idea. And I guess you have of course the latest drivers and firmware updates.

  • awo
    awo Member Posts: 3 Newcomer

    Hello Uwe303,

    Yes, I tried that as I did have it on a front USB port of my pc first - and read a recommendation to use the USB ports on the back as they are directly connected to the motherboard vs the front ports are often connected via a cable that might cause issues with delivering enough power. I tried multiple ports front and back of the pc to be sure.

    Indeed, also the latest drivers of focusrite + native instruments have been installed. To be sure I uninstalled everything (drivers + software), rebooted and freshly installed latest focusrite software/drivers again first, followed by all the NI software.

    Meanwhile - after troubleshooting a bit further - I also reached out to Microsoft. I notice that I can trigger a "crash" the focusrite driver just by playing a test sound multiple times in the system sound settings. I am running an insider preview build I must add (beta release). I read a similar report of another user.

    So .. I do not know why the problem in GuitarRig happens while not in my other Amp Simulators - I will test the others for a longer time to be sure of that statement. It starts to look more a focusrite/microsoft issue.

    Kind regards


  • Uwe303
    Uwe303 Moderator Posts: 2,539 mod
    edited October 13

    Really strange that only gr6 and the windows sound so far can trigger that issue. Have you set the sampling frequency under windows to 48 kHz or to what and what settings in each program. I have set it to 48 under windows and 48 or 96 in all my daws and music applications. Maybe also worth to look into. I was also a long time user of early pre builds of windows, also had win 11 very early, but now as moderator here in the forum I don't want to have the chance that something is not working as it should.

Back To Top