Previous versions of recently updated Kontakt libraries / compatibility with K6 older libraries

1568101117

Comments

  • Asomani Samuel
    Asomani Samuel Member Posts: 2 Member
    edited November 2023

    I can't see some of my instruments in Kontakt 6 after rolling back. But they all show up in Kontakt 7 player. Is there a spesific method on how to do this? Do I have to uninstall the previous version before rolling back? If this is not fixed, they will be missing from my old projects. I'm currently on Kontakt version 6.8.0.

    Please help.

    These are the missing instrument from Kontakt 6.

    Hybrid Keys

    Ethereal Earth

    Analog Dreams

    Lo-Fi Glow

    Modular Icons

    Cloudy Supply

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited November 2023

    @Ced @Alex Nairn @JazzHot Did you open Native Access after installing these libraries for activation ? I forgot to mention this step and updated the post. Does it happen with all the libraries you installed from links provided in this thread?

  • darkogav
    darkogav Member Posts: 70 Member
    edited November 2023

    updated with new info.

    yes. i can also confirm, as of this morning, launching NA and then launching K6, everything works.

    Now what remains is, I still have a few newer Kontakt products that need Kontakt 7. I completley removed Kontkat 7 player because it took over everything and interfered with Maschine.

    If I install the Kontakt 7 player, will the problems return again? Will NI support release a new patched Kontakt 7 player? Will NI support offer the older version of Kontakt 7 player for download? I can confirm things worked with Kontakt 7.6.x player?


    thanks

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited November 2023

    @Neo110 You are right, we have several reports coming in and we're investigating the issue. Can you tell me what libraries are affected?

  • Ced
    Ced Member Posts: 2 Newcomer

    Seems to work now, thx a lot !!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Ced @Neo110 and all the others that had this issue. Investigation is over, issue is now fixed. You only need to restart Native Access.

  • Calagan
    Calagan Member Posts: 143 Advisor

    @Jeremy_NI

    NI is a bloody mess now, but I must say you and your colleagues are making a good job on this forum. Thanks for being there and taking care of our problems. By the way, maybe you should ask some pay rise to your bosses (and ask them to stop taking too much drugs).

  • Neo110
    Neo110 Member Posts: 10 Member

    @Jeremy_NI That's great news! Can confirm k6 is loading all the compatible libs.

  •  cloodstool
    cloodstool Member Posts: 6 Member

    Very happy to see the issue being resolved for some, but restarting Native Access didn't change anything for me. Libraries are still in their latest K7-compatible versions with no option to choose the latest K6-compatible version.

  •  cloodstool
    cloodstool Member Posts: 6 Member

    Reinstalling a library from Native Access doesn't work either, Ethereal Earth should have reverted back to 2.0.2 but stays on 2.1.0 anyway

  • Rem98474498
    Rem98474498 Member Posts: 1 Newcomer

    This entire situation is a joke. Some of your links don't even work as too many people are using them...

  • Neo110
    Neo110 Member Posts: 10 Member

    If you updated the libraries to a version that requires K7 then you might need to download and install the older versions that are linked in the first post here in this thread. I brought up a separate issue where we lost access to libs in K6 even though we didn't update, which wasn't the purpose of this thread, but just needed some disambiguation at the time. Hope that helps.

  •  cloodstool
    cloodstool Member Posts: 6 Member

    Ah my bad, I thought the entire issue had been resolved without the need to manually download each library.

    With how quickly the libraries updated to a point they can't be launched through previous versions of Kontakt, we should not have to go through the hassle of manually downloading each individual library that was broken because of this. Native Access can see what latest full version of Kontakt is activated on an account, and should really only update libraries accordingly.

    I hate to sound whiny like this, but the way this situation is unfolding is difficult to read differently than NI trying to force their users to buy Kontakt 7... I really hope to be proven wrong.

  • darkogav
    darkogav Member Posts: 70 Member


    I don't see it that way. The updated presents work regardless of whether you have a paid version of the full Kontakt 7 or the free Kontakt 7 player. In my case, it totally broke the work flow between Maschine controller, maschine software and Kontakt instruments. It also broke the previous project files I had as the maschine software wasn't able to load the Kontakt instrument and preset that was linked to the maschine project file.

    Quite frankly, my bigger concern with this development is, NI seem to prioritize Kontakt sampled instrument sales and customers over existing Maschine customers.

  • haythamkawar
    haythamkawar Member Posts: 2 Member
    edited November 2023

    Hello,

    On Catalina at my home studio, I downloaded all these previous installers, most of them worked well. the following didn't :

    Session Guitarist Electric Mint

    Noire

    Analogue Dreams

    Ethereal Earth


    I found out that when the installer does not allow you to change the installation path (since in my case I need that because my libraries are on an external SSD) it just doesn't work, even the installer keeps failing.

    I tried changing the default location to the SHARED folder by re-installing the whole library then installing the previous version from this link, it also didn't work.

    Other installers that allowed me to change the location to the external SSD worked very well.


    Thank you for the great efforts but this is very disappointing, I've been using Kontakt since 2007 and this happened for the first time, never had updating problems.

    I hope we can roll back to previous versions in an easier/faster way, or maybe Native Access just doesn't apply any update that is not compatible. for example in my professional studio I have the latest Kontakt version installed, in my home studio, it automatically stopped suggesting updates for Kontant because i'm on Catalina, so the last updated version of Kontakt is 7.4.2.

    I was hoping the same happens with the libraries. why do we have to go through this hassle ? if my system is not compatible, I should not get an update option, just like Kontakt itself.

    This is an effort Native Instruments should exert, not us.

    and I don't have to buy a new Mac computer to solve this issue for good.


    Best Regards.

Back To Top