Previous versions of recently updated Kontakt libraries / compatibility with K6 older libraries

2456717

Comments

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @LostInFoundation Legacy software is different, it's for long time discontinued products and their activation. At the moment we don't have a better sytem for older versions of Kontakt libraries.

  • LostInFoundation
    LostInFoundation Member Posts: 3,985 Expert

    Thank you.

    Having them in NA would be a better system.

    Even like it was before with installation files available in the site would be a better system

  • David Demelier
    David Demelier Member Posts: 1 Member
    edited October 2023

    I also don't understand this way of providing updates that brick people's installations without checking the requirements are met. Providing updates that require a change/fee is frustrating. Now I have native access offering me updates that I must never click unless I buy Kontakt 7 or use Kontakt Player 7 and change hundreds of single track to use it rather than 6.

    For people who would like a no brainer solution it would be great to provide a way to download every licensed products manually and not use NA at all.

  • vallavan
    vallavan Member Posts: 1 Newcomer

    I second a lot of the other sentiments here. Although I appreciate a reasonably straightforward solution being highlighted here, I think that at the very minimum, a note in the changelogs should highlight the minimum Kontakt version (or something to that effect). The lack of this or other feature enhancement as requested by other users simply places a huge inconvenience on users who may keep their libraries up to date.

  • LostInFoundation
    LostInFoundation Member Posts: 3,985 Expert

    @Jeremy_NI could a system keeping updates separated in NA be set up?

    Something like having the “not problematic” updates available as it is now but the updates requiring to update also other componente (Kontakt, OS, computer,…) being under another tab (and clearly stated what you need in order to having them working).

    Or an even clearer system blocking updates if requirements are not satisfied.

    One of the worst buy/install experiences is surely the one of Apple Store, but even there if you try to update an app that requires a newer iOS than the installed one the installation is not allowed, telling you you need to update iOS.

    Can you forward this to @Hayo_NI ?

    NI seems so in need to have Daemon tool constantly analyzing our system…at least use it to know what one can install and what not…

  • LostInFoundation
    LostInFoundation Member Posts: 3,985 Expert

    Never mind. I see from the announcement of KK MK1 being EOL that the things happening lately with all the products being abandoned and discontinued are not unfortunate decisions or accidents, but a clear line of conduct of the company.

    Therefore NI will probably not mind even if users on Kontakt 6 will have problems. Au contraire…it is clearly a politic to force users to update their products, even if they are happy with what they already have.

    So…I guess my suggestions are completely useless.

    Forget about it

  • MrFresh
    MrFresh Member Posts: 36 Member

    This is a good resource, thanks for the links. I have one question, forgive me for the confusion. Isn't Hypha only created to work with K7, and not K6? I am currently under the impression that these installers above are for the last version of K6. Thanks!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @MrFresh You are right, Hypha was made with Kontakt 7!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    Yes, having the previous versions available for our products has always been a concern so we welcome your suggestions. Given the size of our portfolio, it's a challenge and I doubt all versions of our products could be accessible in Native Access in the near future. Please keep in mind that our support has always provided installers for previous versions and will continue to do so, so again, no one forces anyone to do anything.

  • LostInFoundation
    LostInFoundation Member Posts: 3,985 Expert

    I know support provides installers.

    It’s ok when a couple of users ask for a couple of files.

    But, as an example, probably briefly I will ask you for all the installers for all my NI products in order to freeze my computer at a working state with working libraries, in order to then forget NI and NA and move on. And I own K14 Collectors, therefore the files will be A LOT. If many users will do the same…you can see how many things you’ll have to provide.

    If it’s ok for you to have all this work to do when everything could be centralized with a repository, then ok.

    But if support have to do these kind of jobs, it’s not a surprise that then people complain it is slow to answer to requests.

    Well…none of my business in any case…

  • Monochrome
    Monochrome Member Posts: 1,064 Expert
    edited October 2023

    'Lo-Fi Glow', 'Melted Vibes', 'Glaze' and 'Cloud Supply' now got updated as well.

    @Kaiwan_NI Since Jeremy is out of office, any chance that you could add a link to the previous versions to his post?

  • anotherbreed
    anotherbreed Member Posts: 10 Member

    Woah, this is terrible news, wish I found this topic before updating all my libraries (I do that once per month)... I wonder what happens to all my cubase projects where I have all the libraries loaded in Kontakt 6... this move was not professional at all.

  • kar771
    kar771 Member Posts: 1 Newcomer

    Impacted by this as well. Super frustrating how unprofessional the update rollout and this solution feels.

  • Monochrome
    Monochrome Member Posts: 1,064 Expert

    'Melted Vibes' and 'Glaze' got updated as well. Please add them 🙂

    (Maybe add them to Jeremy's original post?)

Back To Top