why is battery4 opening like this in logic pro 10.7.9?

apricotandpearjam
apricotandpearjam Member Posts: 57 Member

hi all.

the only thing i changed since i started working on this project is i updated from macOS12 to macOS13.

since then this is what battery looks like to me in projects created with macOS12.

projects created in logic with battery fresh with macOS13 are fine though.

any ideas?

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    Can you check if you can access the "remote view" in Editor?


  • apricotandpearjam
    apricotandpearjam Member Posts: 57 Member

    hi jeremy. thanks for your reply.

    unfortunately that does nothing and it still displays in the editor mode.

    any ideas?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    Try to go in Logic's preferences and make sure this box is unticked:


  • apricotandpearjam
    apricotandpearjam Member Posts: 57 Member

    thanks.

    yep it’s unticked.

    other plugins open fine.

    its just battery that’s the issue.

    also worth mentioning that no sound is coming out of battery.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @apricotandpearjam Ok, that's weird (and pretty unusual), do Logic and Battery 4 both have full disk access? How to Enable Full Disk Access on macOS

    Does it happen in Rosetta mode as well?

  • apricotandpearjam
    apricotandpearjam Member Posts: 57 Member

    hi jeremy.

    yep it has full disk access as usual and it’s the same in rosetta and native.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    Ok, I've contacted you by email regarding this issue, my colleagues will need to have a deeper look.

  • Rubberfunk
    Rubberfunk Member Posts: 2 Newcomer

    Trying to troubleshoot the exact same issue on an older Intel mac running High Sierra and Logic 10.4.8 - hope you don't mind me joining the thread!

    Battery 4 loads correctly and runs fine in standalone mode, but I can't load the GUI from within Logic. Happening in existing projects (some of which were started as Logic 9 projects) and in newly created projects. Previously created projects with instances of Battery loaded do still playback correctly, but I just can't access the kits to tweak or edit sounds etc.

    When launched standalone today, Battery seemed to have lost the file path to the Factory & User Kit Libraries, which I've now corrected, but this hasn't fixed the issue in Logic, so can only guess it's lost it's way to some other library files containing the GUI preferences / images?

    Any help or suggestions very gratefully received!


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Rubberfunk On the contrary, thanks for jumping in. What version of Battery 4 are you using? Did you uncheck this box as well (or similar one for your version of Logic)?

    For the full disk access thing, this was introduced with 10.14 so that would not work for you.

    What you could try is to totally uninstall Battery 4, as explained here: How to Uninstall Native Instruments Software from a Mac Computer

    Open Logic, close it, then reinstall it. Open Battery in standalone, then open Logic and see if that fixed the issue. If that does not work, I'll also create a ticket for you.

  • Rubberfunk
    Rubberfunk Member Posts: 2 Newcomer

    Thanks Jeremy, I've got ver. 4.1.6 installed, which I think is the latest I can run with High Sierra?

    I couldn't find the Open In Controls View option anywhere in Logic 10.4.8, so perhaps it hadn't been introduced. Other plug-ins (including other NI plugs) are opening their GUI correctly as default.

    I did think about a full Battery uninstall / reinstall, but was worried about accessing the older version of Battery that I'd need to reinstall. Will Native Access sort that out automatically?

    I might try the old faithful trash-the-prefs first as a pre-cursor to reinstalling :) Let you know how it goes ...

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Rubberfunk That makes total sense. Here is the installer for Battery 4.1.6: BATTERY 4.1.6

Back To Top