Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

Problem: Guitar Rig 7 crashes at start - I already tried all things mentioned on help site

mschmahl
mschmahl Member Posts: 13 Member

My big problem is, after installing Guitar Rig 7 on my computer: it crashes at start all the time - I already tried all things mentioned on NI help site, but nothing helped.

Is there another hint how to get it running on my computer?

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    edited September 2023 Answer ✓

    There seems to be an issue with crashes with some Mac users with Guitar RIg 7. We are aware of the issue. It is under investigation. If you encounter this issue, please read carefully and follow these steps here: GUITAR RIG Crashes at Startup

    Sometimes some users miss a few steps, like giving full disk access to Guitar Rig 7 and restarting your computer, as well as resetting the database and deleting the user preferences.

    If all this fails, you can comment in this thread, share your crashlogs or contact our support here: https://bit.ly/NISupport_GR

    We will update this thread as soon as there is more information to share. Our apologies for the inconvenience.

«134

Answers

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Hi @mschmahl

    we are very sorry that you are encountering problems with Guitar Rig 7. In order to help you we'd need some information:

    Does it crash when you start the standalone application?

    What operating system are you using?

    Does your system meet the system requirements? Especially on Windows, does it meet the graphics cards requirements?

    https://www.native-instruments.com/de/products/komplete/guitar/guitar-rig-7-pro/specifications/

    Can you explain how it crashes, i.e. do you see a Guitar Rig 7 windows opening at all or does it not start at all?

  • mschmahl
    mschmahl Member Posts: 13 Member

    Hi Eddie!

    Thanks for your fast reply. My computer is a Apple Mac M1 Max with macOS 12.6.8.

    Guitar Rig 7 is crashing directly after clicking on the application to start it (about 1 sec after clicking on the app symbol apple crash message is shown). No chance to open it standalone and as a plugin in my DAW.

    I already tried all topics of this website several times with no luck: support.native-instruments.com/hc/en-us/articles/360015289417-GUITAR-RIG-Crashes-at-Startup (sorry, it's not allowed to post links)

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Do you happen to have a crashlog available? (Applications->Utilities->Console->Crash Reports).

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Did you try deleting your database folder?

    /Users/yourusername/Library/Application Support/Native Instruments/Guitar Rig 7/Database

  • mschmahl
    mschmahl Member Posts: 13 Member

    and yes. I de-installed & deleted everything several times (as mentioned on that NI help website).

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Thanks for the crash log. We have not seen this crash before and am investigating it.

    Maybe some more info could be helpful for us:

    Which version of Guitar Rig 7 are you using? A licensed PRO or LE version? Or are you using the demo version ?

    Did you install Guitar Rig 7 to an external drive?

  • mschmahl
    mschmahl Member Posts: 13 Member

    It's a licensed Pro version

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Can you please try deleting these folders?

    /Users/yourusername/Library/Application Support/Native Instruments/Guitar Rig 7

    /Users/yourusername/Documents/Native Instruments/User Content/Guitar Rig 7

  • mschmahl
    mschmahl Member Posts: 13 Member

    I deleted /Users/yourusername/Library/Application Support/Native Instruments/Guitar Rig 7

    But it still crashes.

    There is no folder like this on my computer /Users/yourusername/Documents/Native Instruments/User Content/Guitar Rig 7

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    There seems to be something wrong when Guitar Rig 7 tries to read the factory preset files from your drive.

    Can you please check the permissions on this folder? (right-click on it in Finder->Get Info->Sharing&Permissions)

    /Library/Application Support/Native Instruments/Guitar Rig 7

    Inside this folder you'll find some subfolder, two of them called "Component Presets" and "Rack Presets". Try renaming them to something else. Then you'll obviously won't see any presets inside of Guitar Rig 7 but maybe it starts.

  • mschmahl
    mschmahl Member Posts: 13 Member

    System: read/write

    Admin: read/write

    everyone: read

    I just renamed both folders, but GR7 still crashes

    I deleted both folders, but GR7 still crashes

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    Still with the same crash log? This is very odd. We are trying to reproduce this here, but so far could not.

    This is a long shot: Can you try running the standalone version under Rosetta?

    Right-click in Finder on /Applications/Native Instruments/Guitar Rig 7/Guitar Rig 7, select Get-Info and then check the box where it says "Open using Rosetta".

  • mschmahl
    mschmahl Member Posts: 13 Member

    Attached you'll find both crash logs.

    1. after renaming preset folders
    2. running GR7 using Rosetta, which doesn't work, same crash


  • carl.caulkett
    carl.caulkett Member Posts: 7 Member

    @Eddie_NI I can confirm that deleting the `/Users/yourusername/Library/Application Support/Native Instruments/Guitar Rig 7` folder on my system did the trick. Now both the stand-alone app and the VST3 start just fine.

    I'm on macOS 13.5.1 on Mac Mini M1 running in native mode.

  • mschmahl
    mschmahl Member Posts: 13 Member

    Still not running on my system. Deinstalled everything again. With no luck.

Back To Top