Kontakt 7 - issue with MIDI sends back to Kontakt

Options
JMTee
JMTee Member Posts: 13 Member

Hi all,

I upgraded to Kontakt 7 and having an issue in Reaper (DAW) with MIDI sends to Kontakt for drum instruments like "Drum Lab", and "Session Drummer".

I was using Kontakt 5 and would do the following, trying the same in Kontakt 7, but not getting any playback, except for the first MIDI track:

1. Create multiple MIDI tracks with "Sends" back to Kontakt 7 instance.

2. Add the MIDI filter plugin in Reaper to each MIDI track to specify a range of keys.

3. Enable tracks for record.

4. Delete the MIDI items from the Kontakt track (there are MIDI items on each separate MIDI track).


I feel like there must be a setting in Kontakt 7 I need to modify?


Thanks!

Answers

  • Uwe303
    Uwe303 Moderator Posts: 3,398 mod
    Options

    Hello,

    no it should work as you described it, do your midi tracks send all on the same midi channel, channel one is normally set in kontakt for the first inserted device but you can check that in the header of the instrument, if you don´t see it click the i icon.

  • JMTee
    JMTee Member Posts: 13 Member
    Options

    thanks, I partially fixed it, I set Kontakt MIDI to "Omni" and that seemed to fix it, but I have to have the Kontakt track in Reaper in "record" mode to hear sound on the MIDI send tracks

  • JMTee
    JMTee Member Posts: 13 Member
    Options

    also, now I notice that for all Kontakt instances, for other instruments like keys, bass, etc. I have to set Kontakt to "Omni" mode to hear audio in my DAW?

    Maybe I need to change a setting in the routing in the Reaper track? and put Kontakt back to channel 1, what is "Omni" setting, I don't remember it being there in Kontakt 5

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options
  • JMTee
    JMTee Member Posts: 13 Member
    Options

    Thanks this looks helpful, I'll check it out

Back To Top