Play, record and stop button will play sounds instead of triggering functions in EXISTING sessions

Nzumbe
Nzumbe Member Posts: 6 Member
edited August 2023 in Komplete Kontrol

Hi,


before you link me the FAQ post regarding this problem: I've seen it. It doesn't answer my question.


Here's my issue: My Komplete S88 will trigger above mentioned functions just fine when working on a session for the first time. However, once I close Ableton and come back to it later, pressing the corresponding buttons will result in midi notes being played. The only solution to this I've found this far is reinstalling Komplete Kontrol. However, I don't want to do that every time I re-open an existing session.


Any help would be much appreciated.

Tagged:

Best Answer

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert
    Answer ✓

    Deselect that one, the DAW port should not be selected as a track input. May solve the issue

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert

    Post a screenshot of your midi prefence in Live and I’ll likely be able to show you your issue. The DAW port is incorrectly selected as a midi input.

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert
    Answer ✓

    Deselect that one, the DAW port should not be selected as a track input. May solve the issue

  • Nzumbe
    Nzumbe Member Posts: 6 Member

    Bless you and everyone you hold dear.

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert

    You’re welcome

  • Ollie Chugg
    Ollie Chugg Member Posts: 1 Newcomer

    I have the same issue but in Logic. Any suggestions?

  • PDXstudio
    PDXstudio Member Posts: 3 Newcomer
    edited December 2023

    re: Logic

    This happens to me too periodically. While sometimes simply restarting my system fixes it, another solution that's working for the moment is to disconnect the second KK MIDI Input from the sequencer input. I do this by running the data from that input to a monitor object whose output isn't connected to anything.

    To do this:

    1. Open Logic's environment (CMD + 0 or hold option while clicking the Window menu to select).
    2. Navigate to Clicks and Ports layer
    3. Create a new monitor object
    4. Run a cable from Komplete Kontrol S61 Mk2 Port 2 to the monitor object.
    5. Name the monitor for clarity if you'd like
Back To Top