Problems with Kontakt in Logic

Stev01
Stev01 Member Posts: 6 Newcomer
edited July 2023 in Kontakt

Hey guys

I've been using Kontakt 7 for a few months now and have downloaded 2 drum programs (Krimh Drums and Get Good Drums One Kit Wonder Metal) for some original projects that I’m working on, and at the start everything was fine, however over the last 2 months I’ve been having issues with Kontakt and I was hoping you guys would be able to help me. At first I thought there might’ve been an issue with the first drum program (Krimh drums), and I contacted the guys there directly and they tried their best to help me, but unfortunately after trying multiple methods to fix it nothing seemed to work. I was curious to see if using a different program would work, however after purchasing the second one (Get Good Drums) I was still experiencing the same issues, which has led me to believe that there’s a problem with Kontakt 7. I’m using a MacOS Ventura 13.4 with an 8G memory and 494.38 GB of storage and my DAW is Logic Pro X. The best way I can describe what’s happening is when I open up the drum kit for either of them it works fine for a minute or 2, but then when I try to click on a different section of the plug in (going from kit view to settings for example) instead of taking me there it’ll highlight that I’ve clicked on settings but it keeps me in kit view, this happens with anything else I click on from that point onwards. I'll provide screen shots to give you guys a better idea of what’s happening. I have tried plenty of methods such as updating everything (Kontakt, Mac software, Logic), deleting things to free up space, clearing my iCloud,, increasing buffer sizes in Logic and Kontakt, updating the sample pool in Kontakt to relieve RAM stress, freezing tracks, deleting multiple instances of Kontakt but none of these have worked. 

Hope to hear from you guys soon 

Cheers 


Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Stev01 Check in Kontakt in standalone, do you have the same issue when checking different sections of the library?

    Make sure that Logic & Kontakt both have Full Disk Access: How to Enable Full Disk Access on macOS

    If that still happens, where have you installed your libraries? On an external hard drive? What is the format of that drive? It should be APFS, as expalined here: Notes on Hard Drive Formats on Mac Computers

  • Stev01
    Stev01 Member Posts: 6 Newcomer

    @Jeremy_NI Thank you for reaching out to me, I tried the first method you mentioned and made sure to enable full disk access to Kontakt, Kontakt 7, Native Access 2, Logic Pro and NTKDaemon, along with restarting my Mac, however unfortunately that hasn't worked. The second method I looked into and discovered that my laptop was already set to APFS on Macintosh HD and Data. Any other recommendations?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited July 2023

    What if you open Kontakt in standalone, do you have similar issues? What are your audio settings in Logic? What sample frequency?

  • Stev01
    Stev01 Member Posts: 6 Newcomer

    @Jeremy_NI When I open Kontakt on its own it seems to be working fine, none of the regular issues pop up. My audio settings for Logic audio is buffer size at 256, buffer range is set at large, process buffer range at medium, hot disk activity set to average etc. The sample rate is also set to 44.1kHz.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Stev01 Would it be possible for you to do a short video showing the issue?

  • Stev01
    Stev01 Member Posts: 6 Newcomer

    @Jeremy_NI Here's a little video of what happens

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Stev01 What happens if you purge the samples here?

    Do you get control back of the library?

    If you reset the database, do you still get these issues?

    Reinitialize the KONTAKT Database

    • Hold down the alt key on your computer's keyboard and click Go in the Finder menu bar. Choose the appearing Library entry in the drop-down menu.
    • Navigate to Application Support > Native Instruments.
    • Depending on the KONTAKT version you are using, delete the following folder:
    • KONTAKT 5: "Kontakt 5"
    • KONTAKT 6: "Kontakt"
    • KONTAKT 7: "Kontakt 7"
    • Start KONTAKT as a standalone application (not in your DAW).


  • Stev01
    Stev01 Member Posts: 6 Newcomer

    @Jeremy_NI I tried purging the samples but unfortunately that hasn't worked. In regards to reinitialising the Kontakt database, if I delete the Kontakt 7 folder will I still have the app on my Mac and all my progress saved in my logic projects?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited July 2023

    @Stev01 Resetting the database will not affect your projects or usability of Kontakt.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    Did resetting the database help?

  • Stev01
    Stev01 Member Posts: 6 Newcomer

    Hi @Jeremy_NI sorry for the late response, I tried resetting the database and Kontakt on its own works fine but when I open it up in Logic Pro its still having the same issues.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Stev01 I've contacted you by email, I'll forward your case to our Kontakt specialists so they can have a look.

Back To Top