Gui problems with Guitar rig 6

Options
modeplex
modeplex Member Posts: 1 Newcomer

hey there,

since the last update I have interface problems with guitar rig 6. When I open it up, it apears super large, even if it is only on 75% scale. I restarted the FL Studio, opened and closed it a few times.. sometimes it helps, sometimes not. Anyone else seen this phenomenon?

I screen-shotted 2 open instances. One is alright, the other way to big. Check the size-scale. The one with 75% is shown way larger than the other one with 100%.


Tagged:

Best Answer

  • Eddie_NI
    Eddie_NI Product Team Posts: 357 mod
    Answer ✓
    Options

    No, we have not encountered this problem during testing. We'll try to reproduce this here on our end.

Answers

  • PoorFellow
    PoorFellow Moderator Posts: 3,662 mod
    Options

    Could be something buried in either Windows , FL Studio or Guitar Rig 6 .

    Prior to tinkering always backup your stuff , preferably your whole system drive !

    You could try closing everything and then open FL Studio , then (depending on version ?) go to help , then diagnostics , there you should be able to reset stuff then , eventually reboot PC and try again...

    If something buried in Guitar Rig 6 you could try to rename the folder : C:\Users\<USER NAME>\AppData\Local\Native Instruments\Guitar Rig 6 (Please notice though that that folder also contains the Guitar Rig 6 Database) and then reboot to see if that makes any difference...

    With respect to any graphical problems always make sure that your system , including GPU , meets minimum specifications and that your video card drivers are updated !

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    Options

    @Eddie_NI Is this a known issue?

  • Eddie_NI
    Eddie_NI Product Team Posts: 357 mod
    Answer ✓
    Options

    No, we have not encountered this problem during testing. We'll try to reproduce this here on our end.

  • Nikolay Bakalov
    Nikolay Bakalov Member Posts: 2 Newcomer
    Options

    Hey guys


    I could use a little help here

    I just recently updated native access to the latest version (which required me to have an OS version newer than Mojave). So I updated to OS Monterey and it's been a crazy week of installing my whole studio.

    One huge problem that I have here is that whenever I load Guitar Rig 6 Pro (the latest version)

    on an insert on an instrument track in Pro Tools Ultimate 2023.06 every time I click open the plugin to tweak stuff in it I get these crazy sound interruptions as if my buffer size is too low.

    What I remember from last week (before I had to reinstall the whole studio) is that I was able to run many many tracks with virtual instruments at 32 samples buffer size and still be fine with no glitches and sound interruptions.

    Guitar Rig 6 Pro works great in PT with no problems whatsoever until I click open the plugin's interface. That's when I get crazy cpu usage and it becomes unworkable.  

    Today I don't even get sound coming out of Guitar Rig 6 Pro when I click open the inserted plugin.

    The meters of GR6 are jumping but no sound comes out. The second I close the plugin everything works fine.

    -Increased the cache size to 8GB but still the problem persists.

    -Reinstalled Guitar Rig 6 Pro yesterday and still the problem persists.

    -I open the inserted plugin and when I strum my guitar no sound comes out. 4-5 seconds after I've strummed some interrupted sounds come out for a couple seconds.

    -t is only after I switch to 512 samples buffer size that the problem goes away.

    This never used to be the case before.

    -I tried it in a completely new empty PT session with only one audio track with GR6 on it. Same deal. no sound when the plugin is clicked open.

    - I just tried switching to 64 samples buffer size and all of a sudden it works.

    - Tried resizing the GUI to 75%. - still no luck.


    Any ideas or suggestions?


    I have a mac mini 2018 3,2 GHz 6-Core Intel Core i7.  32 GB 2667 MHz DDR4. OS Monterey 12.6.7

    My audio interface is RME FireWire 800

    Pro Tools Ultimate 2023.06

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    edited July 2023
    Options

    @Nikolay Bakalov So in the end, setting the sample buffer to a higher setting fixes the issue?

    If you close the GUI of Guitar Rig, does the performance increase?

    Out of curiosity, does ProTools have full disk access? How to Enable Full Disk Access on macOS

  • Nikolay Bakalov
    Nikolay Bakalov Member Posts: 2 Newcomer
    Options

    @Jeremy_NI Sorry for the super late reply!

    Totally new to forums...

    As far as I remember drastically increasing the buffer size kinda fixed the issue with the interruptions with the GUI open. But then it was unplayable.

    Once I close the GUI the issue is resolved.

    I can play in PT at 32 buffer size with No issues with the GUI closed.

    I just want to able to look at the GUI and tweak it as I play which I can't now without constantly switching between different buffer sizes.

    I'll double check the full disk access thing you proposed and see if it resolves the issue!

    Thanks!!!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    Options

    @Nikolay Bakalov Just checking in, do you still have these issues?

  • MoxThomas
    MoxThomas Member Posts: 4 Newcomer
    Options

    Actually, I have similar observation with Guitar Rig 6 plugin under Windows within Ableton. Audio typically starts to pop for a few seconds if I open the plugin GUI. Sometimes it goes on popping heavily if the plugin instance is loaded with a lot of effects, and the CPU is already under heavy load. It seems like opening/updating the plugin UI needs quite some extra CPU resources, which just results in popping audio, if the buffer is not long enough. But probably this is normal, although I don't experience similar issues with other plugins.

Back To Top