Audio Clipping When Monitoring Incoming Audio

Options
ursalene
ursalene Member Posts: 3 Newcomer

Self explanatory title - is this an issue that can be fixed by something like upgrading the RAM on my computer? I believe it's at 4GB currently and I do remember seeing that the recommended amount was 6.

Answers

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,523 mod
    Options

    It is a matter of audio card settings, not about RAM... increase your latency!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    Options

    Some more details would be useful here, like what operating system and what kind of processor do you have? Do you mean clipping (usually this means a too loud input signal causing distortion) or a different kind of sound issue? What are your settings in Guitar Rig? Sample rate? Buffer size?

  • ursalene
    ursalene Member Posts: 3 Newcomer
    Options

    Running Windows 11 with an Intel i5-7500. I guess a more specific way to describe it would be clicks and pops vs. distortion clipping. So far, have just been scrolling presets in Guitar Rig. When I was trying to use it, it was on a mixed project that already had a bunch of tracks with a few (not a ton of) plugins loaded up. I would say less than 10 plugins on the whole project.

    Not sure about sample rate & buffer size, is that something that is adjusted within Guitar Rig or rather in the DAW (Acoustica Mixcraft 9)? I have been able to see though that my latency is at 14ms which is way higher than I want it to be for recording into the mixed project. I haven't looked into my audio card specs yet to see what's what.

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,523 mod
    edited June 2023
    Options

    Look into your audio card specs (options) yet to see what's what, is the FIRST thing you do! Even before you start install programs...

    Sample Rate: 44100Hz (CD quality) or 48000Hz (Studio quality) are the usual rates. For most audio purposes, you should never go below 44100 or higher than 96000

    Buffer size: 1024 for old MME drivers, 512 for WDM (or similar) drivers, 256 for ASIO drivers (who are the best option). However, consider those as maximum values, for smooth audio. With a modern, fast ASIO driver you can go far lower than 256 (which is really fast response). Your latency at 14ms indicates a buffer size of 512 (which is safe but far from optimal). For a start, go down to 256 and see how your audio is responding.

    In the rare case that your sound card has no options (such as cheap motherboard chips) then anything you need is in the Audio options of Guitar Rig.

    Basic rule: If your audio card runs at 48000Hz (or whatever rate), then also your audio software (including DAW), must run at the same rate! Luckily, in most cards those things are adjusted automatically or by always using your card as a master.

  • ursalene
    ursalene Member Posts: 3 Newcomer
    Options

    Having a lot of trouble with this but I'll do my best to share everything I can figure out.

    I've looked at what I think is the sound card through device manager and as far as I know it's "Realtek Audio"? I don't really know how to figure out any numbers based off of what I'm able to see - it's just a couple tabs about general details and drivers etc.

    My sample rate seems to be at 44100. The options in my DAW to select under sound device are "Core Audio (WaveRT)", "ASIO", and "Wave". When Core Audio is selected, I am not able to select a buffer size and the latency is at 14.0ms, which it cannot be adjusted any lower than. I am able to put it in Exclusive Mode and lower the latency, but when doing this it generates and error message that it is unable to load the sound device and it will neither record onto nor playback the project.

    When ASIO is selected, the latency is lower at 8.3ms, and only one buffer size is available to choose which is 368. However, under this setting I am not able to use my Focusrite Scarlett Solo interface as the recording/playback sound device, so as of now I cannot use this setting.

    Wave mode seems to just be absolutely horrible and when used, I don't even know what the latency is on the monitored audio input but it is absurdly long, well over a full second when playing the guitar plugged into the interface, completely unusable.

    I also cannot figure out where in Guitar Rig to view any options or settings. This is when it is being used as a plugin on a track inside the DAW.

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,523 mod
    edited June 2023
    Options

    -First problem: You said you are running Windows 11, yet you have Core Audio drivers which are for MAC!!! So, first thing to do is to uninstall them!

    -Realtek Audio: This is just a chip to provide basic audio, and since you have the Focusrite, just ignore it. Do not use it, or just use it for your Windows sounds, but never on a DAW! Also, on Sound Devices, set the Focusrite as default device, if it is not already. For both, playback & recording. First select your card (do not double click on it, just select it) and then, click the "Set Default".



    -DAW on any other audio program: Always use ASIO! I can not emphasize it enough. Always! When you apply the correct settings (all steps i wrote on this comment) you shouldn't have any problems.

    -Buffer size: To change this you must go to your Focusrite control panel. It should be able to change it from there, it is impossible to have just one setting. Most possible that is always running at start up and it should have an icon in your taskbar. Since you have audio clipping problem, your goal is to make latency larger, not smaller! Put the buffer size at 512.

    -Guitar Rig settings: You have to adjust them in stand alone mode, not inside DAW. You do this just once and they stay same forever, until you want to change them again. Settings should be there if you click the 3 dots.


    That's all i can do for you. Good luck! :-)

Back To Top