S88 Keyboard switching Templates on its own

OmniFace
OmniFace Member Posts: 12 Member
edited May 2023 in Komplete Kontrol

Urgent problem… we have a show Friday and I need to figure this out.

My band uses the S88 keyboard.

We have a Reaper project that has several songs in it and we use automation to enable/disable various Komplete Kontrol instances for each song.

The keyboard is used exclusively in MIDI mode.

Various Templates are used to split the keyboard and use the octaves needed. Each song has its own template.

For some reason the keyboard is frequently switching to the first (alphabetically) template in the list on its own. This messes up the keyboardist who only has a few seconds to fix it before he should play.

—-

This seems to happen most when using the keyboard to move around the project. I’ve set up some actions in Reaper to respond to the control knob on the keyboard to move around.

When moving to another area of the project and hitting play, the keyboard may switch templates.

Playing the project non-stop usually has no issue.

According to support, and the forums, it’s not possible to use MIDI to change template manually.

So, ****** is happening? Lol

Tagged:

Comments

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,915 mod

    That's a pretty strange one! AFAIK there is no MIDI message or anything that can change the template. Can you reproduce that 100% of the time? Can you check if the Komplete Kontrol plug-in/app disconnects at some point?

  • OmniFace
    OmniFace Member Posts: 12 Member

    Weird right?!

    It happens every practice, but we’re not clear on how to reproduce specifically.

    i have about 20 instances of Komplete Kontrol running, so seeing which it connects to is problematic.

    I am automating the disabling of the plug-ins. So, perhaps that’s the problem. It might be resetting the keyboard or something when it enables a couple instances maybe. I’m not sure I can avoid that though. The CPU usage on the project would be through the roof if I can disable the currently unused instances.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,915 mod
    edited May 2023

    @OmniFace I see, well, it's not really standard operation, I'm not sure I can help. I understand your challenge though. So, when the Komplete Kontrol track is activated the keyboard should get out of MIDI mode, correct? So you have to put it back to MIDI mode? Can you check if these services crash at some point? NIHostIntegrationAgent and NIHardwareService. You can check with TaskManager.

  • OmniFace
    OmniFace Member Posts: 12 Member

    No I keep it in MIDI mode completely.

    Each song has at least two Komplete Kontrol plug-in instances running. Each is listening to a different MIDI channel, and the only way to use the split keyboard with different channels is MIDI mode. In standalone mode you can assign a MIDI channel, but within the VST plug-in it assumes you’re doing it on the track in your DAW so you can’t use the normal mode. You need to use MIDI mode instead.

    Each song is in a Region in the DAW and I automate the instances of Kontrol to enable on song start. On song end, they disable to save CPU. Then some intermission music plays for like 30 seconds until it reaches the next region/song and enables the instances of Kontrol used for that song.

    The problem is that sometimes the keyboard will switch to the first template when that happens, even if the keyboardist has manually switched to the right template (since it’s supposedly not possible to switch via MIDI). Then he’s scrambling to switch to the right template before the song starts.

    Logically it seems that enabling the plug-in instances is resetting the keyboard or something.

    I think the only workaround I can do is enable the instances earlier to give the keyboardist more time. But that’s not an ideal solution.

Back To Top