No effects heard on guitar rig 6

Marko
Marko Member Posts: 1 Newcomer

Hello, newbie here! I need help with my guitar rig 6 pro. I have a presonus audiobox USB 96 interface. I hooked up my guitar on Input 1 and I connected my speakers at the back of my interface. Audio settings connected to the audiobox. Input and output signal present on the software but when I tried to plug in to some guitar presets/effects, it seems that there no effects applied to guitar. Thanks.

Best Answer

  • ScottBrownlee
    ScottBrownlee Member Posts: 4 Newcomer
    Answer ✓

    Hey all -- got some help from the kind folks at NI, but the end problem was simply that a) I had to make sure my interface was correctly hooked up and using ASIO, and b) I had to click the little linked circle button at the top left of the screen -- it was set to "L" instead of the middle button.

    Yep, that simple.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,274 Expert

    It is likely you are "Direct Monitoring" the input. On the front of that interface is a "Mix" control which if you have set it to the Input mix, will simply monitor what is coming into the interface. Make sure that is set to Playback then in your DAW / Program you need to setup the input from the interface as an input and then arm/monitor the software.

    You will also have to check that your audio settings (buffer for instance) are set to offer a low latency signal otherwise you may find the sound will lag behind what you play since effects plugins can add some delay in the chain.

  • williamswelsh75
    williamswelsh75 Member Posts: 3 Newcomer

    I'm sorry to hear that you're having issues with your guitar rig 6 and not hearing any effects. Have you tried updating the plugins? It can often times help resolve these kinds of issues. If you recently installed any software on your computer, it could possibly be interfering with guitar rig. You could also try reinstalling the software or rolling back to a previous version if you think that could help. Good luck!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,700 mod

    @Marko Can you post a screenshot of your audio preferences in Guitar Rig? Input & Output.

  • ScottBrownlee
    ScottBrownlee Member Posts: 4 Newcomer

    I'm going to jump in on this as I'm having the same issue. Here are screen shots of my input and output preferences. I'm using a Scarlett Solo interface, and the only way I hear anything is if I have the guitar input set to "INST" rather than "LINE," and the Direct Monitor switch set to On.

    Interesting that the status shows "unplugged." Any ideas to help?


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,700 mod

    @ScottBrownlee Could it be that you have other audio applications open? Is the exclusive mode on? https://help.ableton.com/hc/en-us/articles/209770485-Disabling-exclusive-mode-for-ASIO-interfaces

  • ScottBrownlee
    ScottBrownlee Member Posts: 4 Newcomer

    Thanks for the answer -- unfortunately, changing it to Exclusive mode did not work, and I don't have anything else running.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,700 mod

    @ScottBrownlee Have you tried these steps? GUITAR RIG Crashes at Startup

    Does that help in any way?

  • ScottBrownlee
    ScottBrownlee Member Posts: 4 Newcomer

    Thanks again for replying. Unfortunately none of that helped...I went through all the steps including resetting the registry editor, running as administrator, checking my sound settings for input/output, etc., and all my drivers are up to date. I can still get a nice clear sound from my guitar when I open Guitar Rig, but no matter what I select for presets or effects, the sound doesn't change.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,700 mod

    @ScottBrownlee I'm contacting you by email regarding this issue, we'll need to get a closer look.

  • ScottBrownlee
    ScottBrownlee Member Posts: 4 Newcomer
    Answer ✓

    Hey all -- got some help from the kind folks at NI, but the end problem was simply that a) I had to make sure my interface was correctly hooked up and using ASIO, and b) I had to click the little linked circle button at the top left of the screen -- it was set to "L" instead of the middle button.

    Yep, that simple.

Back To Top