Re: Komplete Kontrol ScanApp crashes

Maxhombre Member Posts: 50 Member

Hi all

I am running a 2020 Intel iMac 3.6ghz i9 / OSX Monterey 12.6.5 / 128gb Ram / Logic Pro 7.7

I am getting crashes when I scan plugins in the KK stand alone mode, I had some crashes with Waves Headtracker that ive removed from the system now the only crash report I keep getting is with Ni ScanApp just wondered if anyone else had come across this and if there is a fix, ive trashed trashed the NK database and library prefs so it should be fine but ScanApp just keeps crashing on the plugin scan? any advice most welcome.

Best Answer



  • Paule
    Paule Member Posts: 1,328 Expert

    Please go in contact with NI Support and open a ticket.

  • JesterMgee
    JesterMgee Member Posts: 2,274 Expert

    Yeah prob one direct for support. You can scan that crash report and look for any hint of a plugin name which could be the casue for the crash. Likely it is one plugin that is not working or needs an update.

    Cases like this where I have had to figure out the same, usually with Live crashing on loading a project is to remove half the VST plugins from the VST scan folder and let it scan just what is left, see if it crashes, if not, switch the other ones out and repeat until you nail something down. Can take hours to find the cause.

    In my case, Eventide was the issue in one case and an update for their plugins fixed the issue so you may be lucky.

  • Maxhombre
    Maxhombre Member Posts: 50 Member

    Thanks Jester,

    Would the rogue plug-in name be in the crash report? As the crash report is many pages long.

    and how do I save a crash report in full to send over to Ni support?”

  • Maxhombre
    Maxhombre Member Posts: 50 Member

    The crash always happens near the end of the scan and I’m wondering if the scan is alphabetical then I could be looking at Waves plugins first which always seem throw up a few nightlong problems

  • LostInFoundation
    LostInFoundation Member Posts: 3,748 Expert
    edited May 13

    One thing I noticed (and could be useful) is that the scan is “quite” alphabetical. In the end some plugins names appear a second time. I haven’t analyzed it deeply yet, but my suspect is that the scan moves alphabetically first through all vst2 and then through vst3 (in windows). Mac could have something similar happening also for AU. So, if you say that crash happens always at the end, it could have something to do with vst3 or AU.

    Take this with a grain of salt, since it’s only speculations 😉 (but maybe it could be useful to report it to support, helping them to narrow causes)

  • Maxhombre
    Maxhombre Member Posts: 50 Member

    Thankyou so much for your help.

    I’ve just run Apple Disk Doctor on my drive and it says corruption that it cannot fix so have had erase everything re partition reinstalling Monterey as we speak then Time Machine it all back together, I think I need to get an exorcist involved or ‘techorcist’ (incidentally a great name for a tech help guy!.

  • Maxhombre
    Maxhombre Member Posts: 50 Member

    Things got worse, wiped my Mac hardrive, reinstalled Monterey, reinstalled half Terabyte of library, then loads of Native instruments libraries missing or needing repair by accident sent to wrong install path cannot change it,tried what I thought was path for Ni inst library no that’s wrong no idea where it goes So tried to delete all native instruments on computer and start again,been on this for days did take a look if Arturia synths had finally appeared on my system, no chance! After reinstalling no chance, reinstalled Pulse products all successful but Pulse says they are not installed! Time to drink wine!

    what I need to know is

    installation path for the Ni instruments and Maschine expansions where do I point them? Or do they find the path themselves

    or in layman’s terms how to remove all Ni stuff and start again the Ni site says trash the native inst plist but there’s about 40!

    very depressed

  • JesterMgee
    JesterMgee Member Posts: 2,274 Expert

    It may be in the scanlog, I have to often read them for other software I run support on. I see a reference to VST3 in the log so it is being caused by something in your plugins for sure.

    To save a crash report just select all the text in the crash window then paste into a text file and save. You can also post the log here, may be able to see something but please post it as an attachment and not as a post, they can be rather long and full of gibberish.

    EDIT: So I see you went ahead and erased your drive to start again, that would have been probably the last thing I would have suggested at the early stage without first making a restorable backup.

    The plist should show in the name what each one is for, make a backup of them and then delete them and see if that works. If only NA had an uninstall option it would make this kind of mess much better but seems like you may have to do a lot of reinstalling.

  • LostInFoundation
    LostInFoundation Member Posts: 3,748 Expert

    You can see where the installation path for your NI products is in Na settings. You can chose the folders you want there.

    And if you want to remove all NI stuff to start again, I don’t think deleting plist is enough. Probably you’ll have to uninstall them completely.

    But first try to have a look in NA. Once you discover what is the installation path for them, maybe you can relocate them before having to uninstall and reinstall gigabytes of things

  • Maxhombre
    Maxhombre Member Posts: 50 Member

    Many thanks guys, luckily I have a Time Machine b/up so reinstalling again.

    one problem I am getting is a kind of low buffer distortion on the Arturia synth when I play them back I did have a setting of 128 buffer and I put it up to 256 but it’s still there any ideas for a fix it’s like a distortion breakup on the synths, bear in mind I run a large Logic template but have 128gb of ram and have dynamic allocation on. I’m also having to rebuild the full disk access as I open some of the music programs that need full disk access as the Time Machine b/up doesn’t bring back everything

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,679 mod
    Answer ✓

    To completely uninstall a product on Mac: How to Uninstall Native Instruments Software from a Mac Computer

  • MastaHanksta
    MastaHanksta Member Posts: 2 Newcomer

    I have the same Issue with the latest update of Komplete Konrtol and Maschine Never used to do this till I updated through the Native Access App bummer

    ScanApp3 is a buggy ***** software.

    I have a Late 2013

    MacPRO tower 3.5 GHz 6-Core Intel Xeon E5

    Monterey 12.7.1

    64gb of Ram

    MD FirePro D500 3 GB

  • mykejb
    mykejb Member Posts: 244 Pro

    If you don't have a MK3 keyboard you can always roll back to 2.9 as you don't need the latest 3.0 version

    -- Mike

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,679 mod

    @MastaHanksta You can try resetting the database for Komplete Kontrol and Maschine:

    Reinitialize the KOMPLETE KONTROL Database

    1. Go to the following location on your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
    3. Note: The User Library folder is hidden. See this article for instructions to access hidden macOS folders.
    4. Search through the Native Instruments folder at this location to find the KOMPLETE KONTROL folder.
    5. Delete only the KOMPLETE KONTROL folder found here.
    6. Note: Deleting other NI product folders could result in unexpected behavior with other applications.
    7. Reboot your computer and reopen the KOMPLETE KONTROL software to check that the issue has been resolved.

    If that didn't work, get in touch here:

  • MastaHanksta
    MastaHanksta Member Posts: 2 Newcomer

    No such luck gets to the Massive X plugin and hangs

    below is a screen shot .

    never used to do this till u updated the software to the latest Total *****

    fix the ScanApp3 its useless

Back To Top