I Can't Acces Midi Assignment Editor for Komplete Kontrol A25

Romain
Romain Member Posts: 3 Newcomer

Hi,

I use a Komplete Kontrol A25 with a Mac studio M1 OS 12.5.1.

I can't acces the Midi assignment editor in Komplete Kontrol Software.

I've updated my Komplete Kontrol Software V2.9.1. I've updated the firmware of the Komplete Kontrol A25 ( V0.4.1). The Komplete Kontrol software keeps showing this message when I try to enter the Midi Assignment : " Firmware Update Required : Please update the device firmware to access the MIDI Assignment editor".

Has anyone this problem ?

Thanks in advance.

Best Answer

  • Romain
    Romain Member Posts: 3 Newcomer
    Answer ✓

    Resolved.

    The KK A25 was plugged in a USB A hub -> USB A port Mac Studio.

    My mouse, a Command 8 and the KK A25 was plugged in this USBA Hub. Everything was running very well, except for the KK A25 which was running great with all Apps except with Komplete Kontrol.

    I made this : My mouse, a Command 8 and the KK A25 plugged in a USB A hub -> USB C hub -> Thunderbolt 4 port Mac Studio.

    I don't know why it was a problem for Komplete Kontrol. Again the KK A 25 was running great with other apps.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Romain Have you tried to update the firmware?

    Firmware Updater for Komplete Kontrol A 1.4.0 - Mac

    You can find firmwares and drivers in this section:


  • Romain
    Romain Member Posts: 3 Newcomer
    edited April 2023

    Hi Jeremy,

    As i Mentioned in my post , I'm uptodate.

    I still can't access the midi assignment editor.

    Besides I can't control the eight Knobs, they're not responding, neither can I use Midi Learn. I've tried with different instrument and plug in.


  • Romain
    Romain Member Posts: 3 Newcomer
    Answer ✓

    Resolved.

    The KK A25 was plugged in a USB A hub -> USB A port Mac Studio.

    My mouse, a Command 8 and the KK A25 was plugged in this USBA Hub. Everything was running very well, except for the KK A25 which was running great with all Apps except with Komplete Kontrol.

    I made this : My mouse, a Command 8 and the KK A25 plugged in a USB A hub -> USB C hub -> Thunderbolt 4 port Mac Studio.

    I don't know why it was a problem for Komplete Kontrol. Again the KK A 25 was running great with other apps.

Back To Top