How to restore default MIDI assignments for KK S88 Mk2 on Logic Pro

IvoryKeys88
IvoryKeys88 Member Posts: 26 Member
edited April 2023 in Komplete Kontrol

Hi there,

I've had a Komplete Kontrol S88 Mk2 working fine with Logic Pro since I connected them both 8+ months ago.

Today I discovered the DAW control keys such as PLAY, REC, STOP, LOOP have the wrong assignments. They are now playing keys (notes).

I've been trying to figure out how to set the assignments back to the defaults. So far, no luck.

The K S88 still shows up in the Logic Pro > Control Surface Setup, as per normal.

In the Logic Pro > Controller Assignments, I see "Control Surface: KOMPLETE KONTROL S-Series" there, although it has no "Mode" assigned to it, and no assignments. I have no idea if that's normal.

I can also see that the assignments are still there in the "Key Command Assignments" in Logic Pro. For example, this is the assignment for "Record":

As you can see, it shows the correct assignment. But pushing "REC" on the KK currently plays a music note. I've checked the other relevant functions are they also have what appears to be the correct assignments.

I can set a new assignment, and then the respective button works. For example, I can manually set the PLAY button to the Play command on Logic. Although it already had the automatic assignment in place.

Also, the METRO, TEMPO, QUANTIZE, UNDO, and AUTO keys are not lit up, and give no MIDI event to Logic (i.e., I can't manually assign them to any function in Logic as no input data is received).

Can you advise on how to restore the default MIDI assignments?

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited April 2023 Answer ✓

    @IvoryKeys88 Not sure what happened in your case. Sometimes it is enough to delete the file responsible for control surfaces in Logic found here:

    Mac HD/Users/User Name/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:


Answers

  • IvoryKeys88
    IvoryKeys88 Member Posts: 26 Member

    Well, as it turns out, I was able to resolve the issue by simply turning off the keyboard, and turning back on.

    So my question has changed somewhat. Can anyone suggest what might have had the above described effect? I'm glad it was a simple fix, but perplexed how it occurred.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited April 2023 Answer ✓

    @IvoryKeys88 Not sure what happened in your case. Sometimes it is enough to delete the file responsible for control surfaces in Logic found here:

    Mac HD/Users/User Name/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:


Back To Top