How to fix: Guitar Rig 6.3 update broke Studio One 6 / Akai LPD 8 metronome automation

MartyFouts
MartyFouts Member Posts: 5 Member

Prior to the 6.3.0 update I was able to assign a pad on the AKAI LPD 8 to control the Metronome's Mute, something useful for practice versus recording. To do this in Studio One, I would use its Macro tools to assign the button by searching the list of Guitar Rig parameters to find the "Metronome Mute" parameter and then assign it.

The parameter "Metronome Mute" seems to have disappeared from the 6.3.0 update. What parameter replaces is?

Tagged:

Best Answers

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod
    Answer ✓

    It seems that Studio One 6 only lets you assign Buttons to parameters that are also buttons (i.e. on/off). So you need to select a Button on the left side of the setup window in order for the "Metronome Mute" to show up on the right side of the window:


  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod
    Answer ✓

    Yes, you are correct, this is something that we fixed with the 6.3. update as the Mute parameter was incorrectly reported to the host as not being an on/off parameter. I'm really sorry that this now clashes with your workflow. :(

Answers

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    This parameter should not have disappeared. Do you see any other parameters available to assign the Studio One Macro to or is it just the one parameter that is missing?

    If you do a right-click on the Mute button in the Guitar Rig user interface you should see the host automation ID which should tell where in the list of parameters in your host it should appear:


  • MartyFouts
    MartyFouts Member Posts: 5 Member

    I'm confused about how to use the Host Automation ID in Studio One. Using Guitar Rig as a s VST, Studio one presents me with a list of parameters that for Guitar Rig has hundreds of entries. Part way down the list it used to have all of the metronome controls listed. Now it only have volume:


    In the past I would simply have clicked on "Metronome Mute" which would have been near where "Metronome Volume" is now. It looks like Guitar Rig has changed how it responds as a VST and has dropped the parameter.


    So what I appear to need is a translation from the Host Automation ID to a parameter. I had previously thought that "P292" would have replaced "Metronome Mute" But there's no "P292" parameter I can assign.

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    This is odd, I can see that parameter in Studio One on my computer. "P292" just means it is the parameter number 292 in the list of automatable parameters.

    Try a right-click on the empty rack and select "Clean up Automation List".

    Does this help?

  • MartyFouts
    MartyFouts Member Posts: 5 Member

    Thanks for replying patiently. That didn't seem to make any difference. It looks like something changed in GR6's VST handling so that the list of parameters it sends to Studio One 6 is garbled. Some parameters are duplicated many times while other that were present in the previous GR6 release are simply missing: they don't show up with friendly names nor as "Pxxx".

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod

    I just tried again with Studio One 6 (I was using Studio One 5 before) but see the same behaviour as before. But I am just setting up automation on a track, not using a hardware controller. Could you try to set up automation of the Metronome Mute parameter just from the track itself? Does this work?

  • MartyFouts
    MartyFouts Member Posts: 5 Member

    Yes, when I try to use the parameter in automation I can find it, just above Metronome Volume where I expect it:



    but Mute, along with On/Off, Sync, and Tap are still not available when I try to assign controllers to Guitar Rig functions, although they were all present before the update.

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod
    Answer ✓

    It seems that Studio One 6 only lets you assign Buttons to parameters that are also buttons (i.e. on/off). So you need to select a Button on the left side of the setup window in order for the "Metronome Mute" to show up on the right side of the window:


  • MartyFouts
    MartyFouts Member Posts: 5 Member

    Oh. This implies that Guitar Rig 6 prior to the 6.3 update was telling Studio One 6 that "Metronome Mute" was not a button -- since the assignment used to work. But the update fixed Guitar Rig 6 so that it now correctly tells Studio One that "Metronome Mute" is a button?


    OK, that makes sense, but, alas for me, the Akai LPD 8 doesn't have any buttons, only knobs, so basically this means I was getting away with it before because of a bug but the bug's fixed and now I can't do it that way anymore.


    Thanks for the help. I'll go find a different solution.

  • Eddie_NI
    Eddie_NI Product Team Posts: 352 mod
    Answer ✓

    Yes, you are correct, this is something that we fixed with the 6.3. update as the Mute parameter was incorrectly reported to the host as not being an on/off parameter. I'm really sorry that this now clashes with your workflow. :(

Back To Top