Problem with automapping: Root key not correct

dhjdhjdhj Member Posts: 20 Member
edited February 2022 in Kontakt

I've created some samples and named them in anticipation of using the automap feature to lay them out properly. See below

It's my understanding that the first note name (ignoring the initial Sample_), is supposed to be the root key for the sample so that after automaping, the first sample should go from C3 to D#3 but the root note should be D#3

In the setup, I define the first entry as "Using Sample Root"

However, what I'm finding is that while all the samples are positioned correctly, the root name for all samples stays at C3 - I can't figure out how to fix it.

I've attached all the samples (there are about 12, just four notes but sampled at three different velocities). If anyone knows what I'm doing wrong, I'd really appreciate some help.


Example of my sample names -- they're all in the compressed zip file.






  • EvilDragon
    EvilDragon Moderator Posts: 1,000 mod

    So, there is actually a bit of a bug in Automap Setup dialog, where it doesn't properly show you the state of "Read root key from sample metadata if possible" checkbox. This is a global setting stored in registry, but if you enable that checkbox, then close and reopen Automap Setup dialog, it will show as if it's disabled. But it is not!

    So, click that checkbox to activate it then click it again to deactivate it. Then "Using sample root" option becomes "Make root key", which is what you need in your case.

    Should work!

Back To Top