Battery 4 Not seeing my External Drive...

Options
illvibe
illvibe Member Posts: 6 Member

Hello Everyone,

I recently updated my iMac to Ventura 12.2.1.

Battery 4 shows my loaded user kit when I load it but it does not play any down or show any wave form.

I noticed that while attempting to use Battery 4 in Logic Pro X, Battery 4 does not permit me to navigate to my external hard drive where my User Kits are stored.

In contrast though, Battery 4 DOES permit me to navigate to and open kits from my external hard drive.


I'm not sure where to begin since each instance of issue that I've seen on the community site are not exactly like the issue that I am having.


Any assistance would be greatly appreciated.


Thanks

ill

Best Answer

Answers

  • illvibe
    illvibe Member Posts: 6 Member
    Options

    CORRECTIONS:

    Typing too fast I guess...


    *Ventura 13.2.1

    *Battery 4 shows my loaded user kit when I load it but it does not play any SOUND or show any wave forms. The sound names show up in the cells but don't seem to be linked to the actually sound file.


    and

    *I meant to explain that "In contrast though, Battery 4 DOES permit me to navigate to and open my USER CREATED kits from my external hard drive while in STAND ALONE MODE".


    Sorry for the poor typing!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    Answer ✓
    Options

    What is the format of the external hard drive?

    If you give Full Disk Access to Logic and Battery, does that fix the issue? How to Enable Full Disk Access on macOS

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    Options

    @illvibe Any update? Did you check my last questions ?

  • illvibe
    illvibe Member Posts: 6 Member
    Options

    Hello Jeremy_NI,

    I'm so sorry for such a long delay in response. I was finally able to try granting Full Disk Access to Logic and Battery this evening. After granting the access and restarting my computer, I was able to navigate(through an instance of Battery opened on a track in Logic Pro)to my Battery kits on my external drive. I was initially worried as Logic crashed when I tried to open a Battery kit.

    I opened Logic again and tried to load the same kit(as well as others) and it all worked with no issue.

    Thanks so much for your patience, diligence and willingness to troubleshoot/solve this for me.

    I greatly appreciate you and your team!

    Thanks again

  • illvibe
    illvibe Member Posts: 6 Member
    Options

    Hello,

    Now I notice after installing my 9 new Maschine Expansions, when I open Battery 4 and navigate to the expansions and then to the Battery Kit folder, each time I try to load a Battery kit, Logic Pro crashes immediately.

    Any idea what could be the cause and fix for this issue?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    edited April 2023
    Options

    @illvibe Thanks for the update. Glad that some of it works now. About the expansions, where are they installed? On your external hard drive? What is the format of the drive?

  • illvibe
    illvibe Member Posts: 6 Member
    Options

    The new expansions are installed on my iMac's local hardrive at the following...

    Macintosh HD>Users>Shared

    (i'd rather they all be on my external drive but wasn't really sure if that was a good idea or not)

    Logic will crash immediately the moment I click on a Battery Kit that happens to be included with the expansion.


    The same thing occurs when I try to open a Battery Kit from an expansion that is saved on my external drive.

    My hardrive format is Mac OS Extended (Journaled) if that helps at all.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    Options

    @illvibe Does the crash occur in Battery in standalone? Can you try to reset Battery's database:

    Reinitialize the BATTERY 4 Database

    1. Go to the following location on your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
    3. Note: The User Library folder is hidden. See this article for instructions to access hidden macOS folders.
    4. Search through the Native Instruments folder at this location to find the BATTERY 4 folder.
    5. Delete only the BATTERY 4 folder found here.
    6. Open Battery 4 in standalone.

    Any luck after these steps?

  • illvibe
    illvibe Member Posts: 6 Member
    Options

    Hello Jeremy,

    Yes, the crash does also occur in stand alone as well and it's immediate.

    There is no spinning wheel or anything. The program quickly closes.


    I tried the reinitialize process you described but it's still crashing.

    I'm still able to open and load the Battery kits I made but it's still crashing when I attempt to open kits from my expansions.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,290 mod
    Options

    I've contacted you by email regarding this issue, we need more info on your system.

Back To Top