Missing Arturia plug-ins in Komplete Kontrol

This discussion was created from comments split from: Issues: Native Access 2: Dependency installation process is taking longer than normal.

Comments

  • Ronni-Boi
    Ronni-Boi Member Posts: 2 Member

    What is going on...?

    Been using NI Komplete for at least 7 years now, never had an issue till now

    updated to Arturia V9 and updated NI Access on my M1 max running Monterey 12.5.1 Now the library is empty and Audio unit plug-ins are causing the system to become unstable...!!!

    I can't scan the Library or reinstall the plugins and I can't call up any product using Komplete Kontrol

    I'm going round and round in circles... pretty unhappy

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    Hey @Ronni-Boi, we created that thread from your post since it has nothing to do with the original thread.

    Arturia plug-ins are not handled by Native Access. The installation is handled by their own software, The Arturia Software Center.

    Where do you notice the absence of the Arturia plug-ins? In Komplete Kontrol in standalone? In Komplete Kontrol in your DAW? Have you tried in Rosetta and M1 mode? How to Open Your DAW Using Rosetta Does it make a difference?

    Make sure to give Full Disk Access to Komplete Kontrol, your DAW and the Arturia Software Center as well as Native Access and the NTKDaemon.

    Restart your computer and open Komplete Kontrol in standalone, if the plug-ins are still missing,

    Reinitialize the KOMPLETE KONTROL Database

    1. Go to the following location on your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
    3. Note: The User Library folder is hidden. See this article for instructions to access hidden macOS folders.
    4. Search through the Native Instruments folder at this location to find the KOMPLETE KONTROL folder.
    5. Delete only the KOMPLETE KONTROL folder found here.
    6. Note: Deleting other NI product folders could result in unexpected behavior with other applications.
    7. Reboot your computer and reopen the KOMPLETE KONTROL software to check that the issue has been resolved.

    IF that doesn't solve the issue, now that the Arturia Software Center has the correct permissions try reinstalling one of the synths, if it works, then reinstall the other ones.

  • devadip
    devadip Member Posts: 13 Member

    Hi Jeremy,

    I have the same issue with OS Catalina 10.15.7 (MacBookPro Intel) ..

    I continue to delete the Maschine 2 database and Komplete Kontrol database ..I restart my MAC..but I ask to myself: I'm playing music or I'm working as a computer assistant ?

    Please NI (Jeremy look at the arsenal of NI HW and software that I've purchased from 2006 so more than 15 years ago..) your ecosystem is too complex to be managed ....You must simplify your procedures that are so frustrating and some products become unusable.

    My Komplete Kontrol for example, after deleting its database and having restarted my MAC goes in a loop asking to ignore or restart...and continues in the loop....So I've deleted the process by MAC Activity Monitoring utility. Yes, I cannot play music because I've to work as computer assistant (and I'm also an engineer in electronics...).

    Unhappy..

    Regards

    Angelo

  • JesterMgee
    JesterMgee Member Posts: 2,470 Expert

    Just be aware that macOS 10.15 is not supported by any of the latest versions of NI software so if you have issues then this could be the cause:

    https://support.native-instruments.com/hc/en-us/articles/360014900358-Compatibility-of-Native-Instruments-Products-on-macOS

    Need to state what version of software you are using and check that page for compatibility.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    edited September 2023

    @devadip Indeed, you've been with us for a while and have quite a lot of stuff from us (that's an under statement). What you are experiencing should not be systematic, if it happens on a regular basis, my colleagues from support could help to find the cause of the issue and hoefully fix it, but, as Jester mentioned your operating system. Maschine and Komplete Kontrol no longer support 10.15, you can find the versions compatible on the article he posted. If that doesn't fix the issue, let me know and will put you in contact with a specialist.

  • Kymeia
    Kymeia Member Posts: 3,488 Expert
    edited September 2023

    Generally if people are missing NKS versions for Arturia plugins this has often been because the option to install them in the plugin installer was not selected. Arturia software centre has an option for 'silent install' and if that is selected in options, and NKS was not selected in the first time the installer ran, all subsequent installs default to that.

    The solution is simple, open options, deselect 'silent install', close then reopen ASC and install just one plugin and this time the install dialogue should come up, make sure Third Party Content (which includes NKS) is selected and allow the installer to run. After that you can turn silent install back on and all installs will follow that setting.

Back To Top